1

The previous two questions regarding the ACPI error message do not have answers that fix my problem with the same error. I have just upgraded to 15.04 and cannot log in after a normal boot. The login screen shows briefly then reverts to a text only screen and alternates between the two screens on about a 1/2 second cadence. The laptop includes a nvidia graphics card. I am guessing that 219 is referring to an older version of the graphics controller but I could be mistaken.

I can only boot to recovery mode and use the system prompt from that mode. The syslog file did not reveal anything that I could recognize as useful.

What other log files might be informative?

How can I disable the nvidia driver so I can troubleshoot in normal operation?

Thanks.

Since my original post I have started ubuntu with the default video driver and purged nvidia drivers and installed nvidia-current-updates. Now when booting I still see the "ACPI PCC probe failed; starting version 219" message but I can log into the machine. Ubuntu reports an error in the Xorg area that I have yet to chase the details of. I am happy the machine is again usable but would like to pursue the source of the ACPI error. Any assistance would be appreciated.

2
1

I did receive this "ACPI PCC probe failed; starting version 219" error as soon as I received the latest version of Ubuntu (15.04) with the generic kernel 3.19. ???. As soon as I rebooted my laptop the screen went blank (or a black screen) and the laptop just "hung" and would not proceed further. The only option for me was to power off and then power on. Upon booting, Ubuntu went to the " "advanced ubuntu options" in GRUB " and by selecting the prior available kernel 3.18. ??, my laptop booted successfully and was quite usable as before.

As from April 23, 2015 until this morning, May 20, 2015, I had to use the ... power on, power off, power on, select the kernel 3.18. ?? to use my laptop ... . On the morning of May 20, 2015, Ubuntu made availble the latest Kernel 3.19.0.18 to download and now my laptop boots up properly as before with no errors.

As is the same with Microsoft Windows, the developers at Ubuntu must always update their operating systems and sometimes minor things do get missed.

My laptop is a Dell Inspiron B120 with a "Intel® Celeron(R) M processor 1.40GHz", "Intel® 915GM x86/MMX/SSE2" graphics card, 32 bit processor, and 2 Gigabyte RAM. It is a solid laptop but struggles with Windows as Windows can be quite hefty on older laptops which is why I chose Ubuntu as it is really quite a light operating system that offers similar functionality as Windows.

I appreciate Ubuntu very much and hopefully, future upgrades will explain a little more clearly some missed errors whether critical or not.

Anyway, I understand the tribulations for the operating systems programmers and the effort required to update operating systems to keep them secure.

I wish them well.

0

Not allowed to comment yet so I'll leave this as an answer. I am also having this problem and it appears to be down to the nvidia drivers. If I completely remove them my laptop is as good as dead - I'm able to login but painfully it's painfully slow.

It appears we're not the only ones, I've got my hopes pinned on this question being answered Ubuntu 15.04 flashes log-in screen then black

My laptop was working with 15.04 installed up until I tried to change the resolution and removed the working drivers by mistake. Now I'm in the same boat as most it seems.

0

I have found a solution to this problem which doesn't require any workaround. In the end I have the Nvidia driver.

My configuration is: Xubuntu 15.04, with a GeForce 960 GPU.

I get the same message than you after installing Nvidia driver through apt-get. So here is my solution:

Boot in rescue mode and select Resume directly. It should allow you to boot normally. Then to fix the problem:

  1. Go to Cuda Downloads and download the Runfile Installer you need for your distribution.
  2. Ctrl + Alt + F1 and log to your account.
  3. Stop all graphics: sudo service lightdm stop (or sudo service dm stop).
  4. Purge all Nvidia stuff: sudo apt-get remove-purge nvidia-*.
  5. Go where you put the Runfile, make it executable and run it with the following commands:

    chmod u+x cuda_7.*_linux.run
    sudo ./cuda_7.*_linux.run
    
  6. Follow the instruction, you may not want to install the Cuda toolkit or driver it is up to you I guess. (I wanted them so I installed them).

  7. Configure the X server: sudo nvidia-xconfig.

  8. reboot: sudo reboot.

0

If you are experiencing graphics issues it may be related to this bug https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-346-updates/+bug/1454817

However please read the following before you assume that issue

ACPI PPC Probe failed. Starting version 219

These are two separate messages

ACPI PPC Probe failed.

Starting version 219

The first is related to a new ACPI interface PCC (Platform Communication Channel) https://github.com/torvalds/linux/blob/master/drivers/mailbox/pcc.c

Which is defined by UEFI http://www.uefi.org/ACPIv5.1

The second is related to systemd the program start process manager for Ubuntu 15.04 and above the current version of systemd is 219 so the message Starting version 219 is just stating the boot process has begun. Noted here: https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1432171

These messages are return prints of mutually exclusive events, they are not related to each other nor are they directly related to the Nvidia graphics issue.

You can see these messages without having any nvidia driver issues. Please do not assume you have a driver issue if you see these messages. Your PC may boot to the desktop after seeing one or both of them.

You may see this in your output of journalctl

sodu journalctl

Aug 16 23:10:55 x kernel: PCCT header not found.

Aug 16 23:10:55 x kernel: ACPI PCC probe failed.

These are the returns if the code does not find the ACPI interface which only some very new devices have or if it actually fails to read/write to the interface if it is present. The code was written for upstream releases. If you read the emails in the filed bugs below you will find information that supports my statements and you can read the return messages in the code itself in the github link above.

http://permalink.gmane.org/gmane.linux.power-management.general/56400 http://comments.gmane.org/gmane.linux.acpi.devel/73411

I hope this helps to clarify some things.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.