0

I have a 120 GB SSD in my laptop, and it runs windows 8.1 (not preinstalled). I have countless times dual or triple-booted the laptop when I ran Windows 7. Now I want to dual-boot it with Win 8.1 and Ubuntu 15.04, but Gparted and the Ubuntu installer wont let me re-size the sda2 partion for it to happen. I know I have about 35 GB of free space on it, and my plan is that Ubuntu should have around 20 GB, so that I still have room for various downloads and temp files on Windows.

Gparted on the live USB Description of sda2

2

Have you tried using Windows to resize the partition? I have done this several times with Windows 8.1 and it works very well. It will tell you, if resizing is not possible.

  • I tried to re-size it via disk managment, but it said the disk was damaged. So now I am running a chkdsk /f /r and seeing if that helps solve the problem. – Rasmus Mathiesen Apr 25 '15 at 10:36
  • Windows will only let me re-size it by 7 GB - that just not enough, I can barely install Ubuntu with that – Rasmus Mathiesen Apr 25 '15 at 10:56
  • 1
    Windows is usually not able to move certain files. Try switching hibernate and pagefile temporarily off. Defrag might also help. – Michael Schlueter Apr 25 '15 at 11:15
0

I found an answer to my problem.

I wasn´t able to shrink the windows partion by more than ≈ 7 GB (I think it´s because Windows won´t let you go under 30 GB free space) in Windows 8.1 Disk management.

I therefor downloaded Partition Wizard and used that to shrink my SSD to what I wanted (I shrinked it by 20 GB, leaving me with ≈ 15 GB of free space left on Windows. After this I booted up the Ubuntu install and choose to install Ubuntu along side Windows 8.1

0

I tried to install Ubuntu 15.04 on an Acer Aspire-E15 laptop which has the preinstalled Windows 8.1 and had no Linux before. My first reboot after finishing the Ubuntu installation still automatically went to Windows 8.1 without any clue.

The following are the steps I used to solve my problem and may also be useful to those people who want to get the latest Ubuntu on their Acer laptops.

  1. Tap F2 while restating to get InsydeH20 Setup Utility open

  2. Go to Main and enable F12 Boot Menu (by default it is disabled)

  3. Go to Security and enter Supervisor Password

(I simply did this because I think running Secure Boot requires the password. BTW, the security boot mode cannot be disabled on the Acer laptop.)

  1. On the same Security menu, go down UEFI file selection and press Enter showing up a new Security screen

  2. Press Enter on the label HDD0 and then on EFI to get the ubuntu .efi files

  3. Select one ubuntu .efi file

(I had two shimx64.efi and grubx64.efi and simply picked up the latter.)

  1. Press F10 to save and exit

  2. The laptop may still get into Windows 8.1 at this time. If it’s the case, reboot and tap F12 to get the boot menu and select the EFI File Boot. Or reboot and tap F2 again…

  3. On Setup Utility go Boot menu and move EFI File Boot grub up to the top

  4. Press F10 to save and exit… Now the GRUB menu should come up by itself

Cheers,

Dr. Ying Xiong ca.linkedin.com/in/yxiong99 “Wireless gateways connect everything to the Cloud”

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.