2

I am running Ubuntu 15.04 (Vivid Vervet) with 3.19.5-031905-generic #201504211114 kernel and GNOME Shell 3.14.4 on a Samsung NP370R4E laptop.

When I boot up, I see

[1.079026] ACPI PCC probe failed
starting version 219

on my screen but boot proceeds and I get to the log-in screen.

However, I am unable to adjust my screen brightness - it remains at maximum brightness when connected to a power source and doesn't budge when I use fn+f2 or f3 to change the brightness. Also, when shutting down or rebooting, machine hangs at the shut down splash screen (after sending the power off or reboot message) and I have to power off manually by holding the power button.

I used to be able to make the laptop sleep by closing the lid but that doesn't happen now either.

Also, I have been having these issues since 14.10 and it was due to these problems that I installed this upstream kernel after getting to 15.04 : I figured https://bugzilla.kernel.org/show_bug.cgi?id=84561 must have been committed to this release.

Edit : this isn't a duplicate of What is [ 0.4486641 ACPI PCC probe failed] starting version 219? : my computer does boot to the login screen and it isn't the case that my display manager isn't loading - gdm loads fine. Instead, ACPI appears to be completely unable to influence the power peripherals of my computer (if that is the right term)

Edit : is it alright for me to try and bump 84561 at bugzilla.kernel.org? Or is this even the place to ask this.

4
1

I believe the 'ACPI PCC probe failed' is a separate issue from your display brightness. I base this hypothesis on the following:

  1. http://permalink.gmane.org/gmane.linux.power-management.general/56400
  2. Similarly: http://comments.gmane.org/gmane.linux.acpi.devel/73411
  3. You have stated you no longer see the 'ACPI' message after you upgraded
  4. You still see 'Starting Version 219'
  5. The boot process is controlled by 'Systemd' current version 219
  6. I see 'ACPI PCC probe failed starting version 219' only after a previously hibernated or suspended session has been resumed and then rebooted, or shutdown and then started
  7. There are many questions on AskUbuntu and many other sites regarding this message and each seem to have a different set of repeatable steps to replicate the message
  8. The 'ACPI' message is a bug: https://bugzilla.kernel.org/show_bug.cgi?id=92551

My research shows that the kernel is looking for the Platform Communications Channel Interface which is a new ACPI interface that not too many devices support yet. The error return messages are PCCT header not found. followed by ACPI PCC probe failed. Per Ashwin Chaugule code creator found here https://github.com/torvalds/linux/blob/master/drivers/mailbox/pcc.c

My relevant journalctl output

sodu journalctl

Aug 16 23:10:55 x kernel: PCCT header not found.

Aug 16 23:10:55 x kernel: ACPI PCC probe failed.

In all I think there are too many variables for so many seeing the same message. Statistically this makes your unique issue a higher probability that it is unrelated to your display brightness controls. Further, if you read the emails completely in the first two points in the list above I think it is clear that a work around was developed inside the code the developers created that would be attended in the future for upstream releases.

I know this does not completely answer your issue but I am hoping it will focus others with more Linux Ubuntu 15.04 knowledge and experience to a solution or a working hypothesis to resolve it.

2
  • Thanks for your reply; I got the same impression earlier and was hoping that I would be wrong.
    – Hari Babu
    Aug 18 '15 at 15:33
  • You are welcome, it was an issue I was looking into for my own peace of mind but your question was the catalyst that got me researching hard for it. Thanks for the solid rep bounty :) Aug 18 '15 at 19:34
0

I had the same issue.

I resolved it installing Kernel 4.0:

$ wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-headers-4.0.0-040000_4.0.0-040000.201504121935_all.deb
$ wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-headers-4.0.0-040000-generic_4.0.0-040000.201504121935_amd64.deb
$ wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-image-4.0.0-040000-generic_4.0.0-040000.201504121935_amd64.deb
sudo dpkg -i linux-headers-4.0.0*.deb linux-image-4.0.0*.deb

it worked with gdm and lightdm display managers.

3
  • Thanks. But this didn't work in my case. I still see the 'starting version 219' message though I don't see the 'ACPI PCC probe failed' message. The display brightness is still beyond my control and the laptop won't shut down on its own =/
    – Hari Babu
    Apr 28 '15 at 9:23
  • What about kernel v-4 is it work with fglrx driver without troubles?
    – user402960
    May 2 '15 at 3:18
  • I am using the i915 driver. fglrx has never worked for me for some reason. However, with the 4.0.0-040000-generic #201504121935 kernel, there is no luck. However, I am not sure if this is a problem with the display driver. Because it is the brightness and sleep function that aren't working, I guess it is a fault with ACPI.
    – Hari Babu
    May 2 '15 at 9:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.