5

I have done clean install recently of Ubuntu Desktop 15.04.
And I was able to log in to the graphical environment until I enabled "boot to text" like said there: How do I disable X at boot time so that the system boots in text mode?
1. commented out

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
2. added "text" to
GRUB_CMDLINE_LINUX="text"
3. uncommented
GRUB_TERMINAL=console
4.
sudo update-grub
5.
sudo systemctl set-default multi-user.target
Now system does not load gui, just text prompt.
When I want the GUI, I start it using
sudo systemctl start lightdm
graphical login prompt appear, but when I pass the password screen flickers and again password prompt appears.
I even reverted all changes back: grub file and
sudo systemctl set-default graphical.target
How can I log in to the GUI now, please?

3

Based on the bug report, reported March 21, 2015 Ubuntu 15.04 Xserver does not start or freezes with systemd + lightdm. More detail regarding the impact of this change and how to switch from systemd to upstart and back again is available on this page.

To check to see if your system is using systemd vs. upstart you can test by issuing the command sudo initctl version which will return upstart if upstart is handling init. another useful method is to issue the command dpkg -S /sbin/init which will tell you which package installed it (in my case on 14.04 it's upstart) you can find more very good answers on how to do so from our friends at Unix & Linux. Further detail regarding identifying the init system is also available.

To see if your lightdm works under upstart as designed, you can install the upstart-sysv package, which will remove ubuntu-standard and systemd-sysv (but should not remove anything else. Give the developers a heads up if it does!), and run sudo update-initramfs -u. After that, grub's "Advanced options" menu will have a corresponding "Ubuntu, with Linux ... (systemd)" entry where you can do an one-time boot with systemd.

You can revert back to systemd installing systemd-sysv and ubuntu-standard packages.

Another option appears to be to use gdm under systemd instead of lightdm under upstart.

Further sources (not linked elsewhere):

https://unix.stackexchange.com/questions/196166/how-to-find-out-if-a-system-uses-sysv-upstart-or-systemd-initsystem

1

I am also having problems with lightdm refusing to show up. In my case, I have both "plain" ubuntu and kubuntu-desktop, so I chose sddm as login screen (sudo dpkg-reconfigure lightdm allowed me to select which login manager I wanted). Maybe installing sddm (if you don't want all of Kubuntu desktop) might be a workaround (I don't know detailed steps on how to install and configure ONLY sddm, though). I'm on a Haswell integrated graphics setup.

gdm seems to work, too: https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/1434799

1

I had this problems after upgrading from 14.04. I restarted the system and went in to a terminal and tested the login at the terminal and determined my logins worked. I logged in as root and did apt-get update and saw an error that stated that I needed to run dpkg --configure -a. I ran the command and let it reconfigure the system. After it was finished( about an hour) I rebooted the system and was able to log in to the graphical login.

1

To solve my problem I have to change ownership of .Xauthority file from root to my user like this:

chown myusername:myusername .Xauthority

where myusername is my username.

0

My ordeal has been with adding or removing *.desktop files on my machine, and getting a black screen with only a cursor and the "search bar" from alt-F2.

The first time, I tried to manually add a *.desktop file to /.local/share/application for Sublime Text, and that messed up my machine.

The second time I added a launcher for Android Studio using the software's shortcut to do so, which creates a *.desktop automatically and places it in /.local/share/applications. Right after that, my OS crashed, and when I tried to reboot and log back in, I saw the black screen.

The third time, which happened 3 hours ago, I deleted a duplicate *.desktop file from /.local/share/applications, then logged out. When I logged back in, I encountered, yet again, this issue.

I'm at my wit's end with this. I had to reinstall Kubuntu 15.04 after the first occurrence. For the second, I had to do some convoluted things which I wish I had made a note of, but also included creating a new user and transferring all my data from the old user account.

I guess I will have to go through the whole ordeal again, but this is concerning. If it's happened 3 times in one week, it is bound to happen for the next who knows how long until a fix is in place....

UPDATE

I was able to get my desktop back by running sudo apt-get install kubuntu-desktop. How the hell did this get uninstalled, I have no idea, but there you go. I hope this helps someone out there.

0

I had similar issues after trying to add some startup scripts (black screen with cursor and a half-active search box). In my case deleting .cache directory from home dir unlocked my system. At this point I think that my problems originate from sudo not respecting -S switch when used in script. No idea why, as in Konsole it works OK...

0

After updating 14.04 to 14.10 and then 15.04 I got caught in the login loop. After much poking around at problems with nVidia drivers, they were not much help. I have an HP Pavillion with AMD CPU & Drivers. Here were the simple steps that worked:

Ctrl-Alt-F1 to get a console prompt (non-gui)

dkms status #shows that fglrx-core was installed
sudo apt-get purge fglrx-core
sudo apt-get fglrx-updates
dkms status
sudo reboot now

Then all was well.

0

I too suffered the same problem today. I was unable to login onto 15.04 graphical system with the latest kernel. I own a DELL vostro 3546 ubuntu laptop with nvidia 2gb graphic card. So i went into grub-> Advanced options for Ubuntu -> Ubuntu kernel 13.13 generic (used by 14.04 Ubuntu) and I was able to boot into 15.04 Ubuntu.

Hence i guess the graphic driver is unsupported for new kernel.We have to wait till the fix.

Now i'm figuring out how to load 13.13 generic kernel by default.

protected by Community Oct 15 '15 at 2:09

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.