Hi I'm trying to access my home directory on my laptop hard drive through a live usb. I cannot boot into the OS on the hard drive and the home and root directory is encrypted. I have the encryption key but when I try to run the tool to gain access it pops up for a second then disappears and when I run the command in Terminal it says "Encrypted private directory is not setup properly". What are my options on getting into the directory? I really need to get the data off my laptop.


I had a similar issue. I was able to solve it using the instructions here:


The key for me was to first navigate to:


before I ran the command:

sudo ecryptfs-recover-private .Private/

Before I just navigated to /media and ran

sudo ecryptfs-recover-private (mypartition)

I entered my passphrase and I received a SUCCESS notification. Unfortunately, I was still unable to access /tmp/ecryptfs.(randomcharacters)

It took me two days to finally find a solution that worked.

  • If you get a "mount: /tmp/ecryptfs.MV9Ov7BQ: mount(2) system call failed: No such file or directory." error, run sudo ecryptfs-manager, just exit with pressing 4 and then run sudo ecryptfs-recover-private .Private/ again. Credits to the commenter at unix.stackexchange.com/questions/285541/…
    – Omer Sabic
    Oct 27 '19 at 8:05

After many days of worry and trying to follow many other guides this one worked perfectly! http://www.howtogeek.com/116297/how-to-recover-an-encrypted-home-directory-on-ubuntu/

  • 4
    Hi, would you kindly post here the exact steps you followed to recover your encrypted home directory and then provide the link afterwards. The linked site can go offline in which case your answer won't help anyone.
    – Parto
    Apr 25 '15 at 7:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.