Is it reasonable to install a current version of Evolution (say 3.16.1) on Ubuntu 14.04? I added the recommended 'ppa:fta/gnome3', but I'm still only offered 3.10.4 from the Ubuntu archive. It seems the ppa currently only supports Vivid and Utopic. I downloaded the tar for 3.16.1, however building this on Trusty seems onerous. I run './configure', read the failure message, google for the package containing the failed dependency, install the package, and repeat. I've one-by-one installed several packages already and don't feel like the end is in site. Is there a better way to accomplish this? It looks like at one time the ppa offered '3.13.7-fta1.2~trusty'. Is there a way for me to get that package? Or was it removed because it didn't work?

  • You can get a lot (probably all) of dependencies by sudo apt-get build-dep evolution.
    – muru
    Apr 25, 2015 at 4:12
  • E: Unable to find a source package for evolution -- Does this imply I have some configuration error?
    – proximous
    Apr 25, 2015 at 13:29
  • 1
    Uncomment all lines starting with deb-src in /etc/apt/sources.list and run sudo apt-get update and continue with apt-get build-dep as suggested. Apr 25, 2015 at 15:28
  • That gets me further, however now I'm stuck with No package 'libedataserverui-1.2' found...is this a loosing battle? I can't find any package that contains it, not to mention the other version issues like Requested 'camel-1.2 >= 3.16.1' but version of camel is 3.10.4 Should I expect to be able to succeed without heroic effort?
    – proximous
    Apr 25, 2015 at 20:07
  • @proximous you'll probably want to try after removing the PPA. It seems to be causing problems.
    – muru
    Apr 25, 2015 at 21:00


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.