1

I installed Ubuntu on a different drive to Windows 7, but after installing, Windows 7 disappeared on the boot screen, that is I don't have options to boot Windows 7, the computer start up directly to Ubuntu. Even if I choose to boot from the hard drive Windows 7 is installed, the computer still goes straight to Ubuntu. I checked the Windows 7 drive on Ubuntu, everything is still there, and I know that I didn't do anything on this drive when installing Ubuntu.

When install Ubuntu, I noticed that Windows 7 is installed on sdc, so I installed Ubuntu on sda.

I have tried using Windows 7 installation CD to repair, but it cannot find any windows system installed. Anyway I still performed 'bootrec /FixMbr','bootrec /FixBoot' and 'bootrec /RebuildBcd' under C drive in commmand prompt (cause I know win7 is in C). Then the third command detected my installed windows 7 but when I type Yes to adding it to the boot list, it shows "The volume does not contain a recognized file system".

Then after that Ubuntu also failed to boot, my computer simply shows "missing operation systems". However, I can fix Ubuntu quickly using a live Ubuntu from my installation usb and Boot-Repair. I just can't get access to Windows 7 again.

Here's the link to BootInfo summary from the Boot-Repair. I am totally new on this, would anyone please help me?

http://paste.ubuntu.com/10882149/

  • You show Windows on sdc1. But when you installed it to that drive was sda or sdb set as default boot in BIOS. Then Windows put its 100MB boot partition on that drive. The boot partition has bootmgr & BCD which are missing from your sdc1 install. You should be able to set sdc as default boot in BIOS, make sure boot flag is on sdc1 as it is now, and run your Windows repair to make sdc1 bootable. It will add the missing files. Really a Windows issue. – oldfred Apr 25 '15 at 3:38
0

There is no problems with windows 7 installation. You just press and hold Shift during loading grub. For permanent change edit your /etc/default/grub file and place a # at the start of the line GRUB_HIDDEN_TIMEOUT=0. Save changes and run sudo update-grub to apply changes.

Documentation: https://help.ubuntu.com/community/Grub2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.