I've just installed Maverick, and while it seems to work so far, Empathy is unable to connect to my MSN account. I've verified that Pidgin can connect.

I've tried looking at the Empathy debug log, but all I see is:

Starting butterfly 0.5.14: telepathy-python 0.15.17, papyon 0.5.1

Failed to create Connection

Any suggestions as to what's going on here, and how to fix it?

  • Does this always happen, happen sometimes or stay stuck after its happened (until a reboot or some other sort of event)? – Nick HS Oct 18 '10 at 11:16
  • Are you connecting behind a proxy or an open connexion ? – Nicolas Schirrer Oct 19 '10 at 20:37
  • Actually this was happening for me as well a few hours ago. It is fixed now. Try to kill butterfly process and then try again. – NightwishFan Oct 20 '10 at 16:33
  • On my home machine, this always happens --- red error icon, connection failure. On my work machine (on a different network) it just never connects --- continuous flashing icon and 'Connecting...' message. Work has a transparent HTTP proxy, home has an explicit proxy on a different port, but that shouldn't apply here because MSN doesn't use HTTP, right? – David Given Oct 21 '10 at 11:16
  • I have the up to date version of empathy and i changed a repository and still no connection.... ubunutu know? – Elliott Jan 11 '11 at 0:29

Removing telepathy-butterfly (complete removal in synaptic) did the trick for me - no need for reinstallation.

  • Scarily, this works. My existing MSN account went funny, so I had to remove it and readd it, but now it connects fine --- I assume it's now using Haze to connect via libpurple rather than the native telepathy implementation. Thanks! – David Given Oct 21 '10 at 11:21
  • The correct solution is either edit RequestMultipleSecurityTokens.py or wait for the patch to land in the upgrades. – tutuca Oct 22 '10 at 22:45
  • Switching to pidgin (which uses libpurple natively) worked for me – teambob Nov 10 '11 at 0:43

It looks like Microsoft released a new version of Windows Live Messenger and made incompatible changes on the server side.

There is a Launchpad bug here: https://bugs.edge.launchpad.net/ubuntu/+source/papyon/+bug/663670. It looks like there is a proposed update ready for testing (cfr. https://bugs.edge.launchpad.net/ubuntu/+source/papyon/+bug/663670/comments/52).


Until the official patch goes through, for those who cannot wait, type the following in a terminal (tested on Lucid and Maverick):

gksudo gedit /usr/share/pyshared/papyon/service/description/SingleSignOn/RequestMultipleSecurityTokens.py

Then find:

gksudo gedit /usr/share/pyshared/papyon/service/description/SingleSignOn/RequestMultipleSecurityTokens.py

And change that to:

CONTACTS = ("contacts.msn.com", "MBI")

Now just save and restart Empathy and it should connect again.


Some things you might want to try,

  • First try to remove and recreate your account information for MSN, open Empathy and hit F4, then select your MSN account and click remove, and re add the account.
  • If that doesn't work then try reinstalling empathy-common by hitting ctrl-alt-t typing sudo apt-get remove empathy-common in the Terminal, and then reinstall.
  • Try sudo apt-get remove telepathy-butterfly in the Terminal, and then reinstall it.
  • Done, done --- no change, I'm afraid. (I assume you wanted me to reinstall empathy after removing it?) – David Given Oct 11 '10 at 23:29
  • Yeah I forgot to include that vital step. I am using the same version of Empathy and have had no problem connecting. Did you do a clean install and added your accounts or did you upgrade and it carried over your account information? Are you using the AMD64 build? When you enter your username are you including the @hotmail.com or @MSN.com or which ever your full email address for the account is? – NW15062 Oct 14 '10 at 1:16

My Empathy has been working since the 10.4 release and within the last day, MSN stopped connecting. I resolved the issue by apt-get removing the telepathy-butterfly and then removing my MSN account from within Empathy. I then re-added the MSN account and it works.

It is my understanding that Emapathy can either use the butterfly or haze module to connect to MSN, by removing butterfly, I forced it to use haze.

  • Thanks Chris you saved my life! :* your method worked thanks a lot once more: Remove Telepathy Butterfly: sudo apt-get remove telepathy-butterfly Then remove my msn account from empathy. Then creating it again and logging in. It worked perfectly. God bless you. – Hammad Jan 19 '11 at 2:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.