4

This question already has an answer here:

I'm running 14.04 on a new XPS 13. In order to support the newer hardware, I'm running a mainline 3.19 kernel.

Hibernate resume has been iffy with the entire 3.19 kernel line, but recently (3.19.5) pm-hibernate no longer works at all. The screen will either a) switch off momentarily, then back on with all inputs frozen or b) switch off entirely, and fail to resume upon power on (despite displaying the correct resume-from-uuid message).

I have enough swap space (and it has worked in the past), I have checked that the uuid is being correctly referenced, and nothing seems particularly amiss in /var/log/pm-suspend.log (last 200 lines here: http://pastebin.com/1dvyHhmQ)

Thanks for your help.

marked as duplicate by jokerdino May 26 '16 at 18:09

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Having the same problem: Sometimes when i try to resume from hibernate the power button is lighted up but the screen is black, also the mouse doesn't seem to have power (light). My pm-suspend.log: pastebin.com/HqCkyugV – enspandi Jun 26 '15 at 17:16
  • @enspandi I may have found the problem on my end, but would like to see whether it helps you as well before posting it as a solution. In my case, because I was running a newer kernel my initramfs wasn't correctly configured. If you want, try this and let me know how it goes: make sure you have grub configured to resume from the uuid of your swap GRUB_CMDLINE_LINUX="RESUME=UUID=<your uuid>", then do uname -r to get the kernel name, and finally sudo update-initramfs -u -k <your kernel name> and sudo update-grub. Reboot and see if you can now successfully use pm-hibernate. – glarue Jun 26 '15 at 19:01
  • I cannot reproduce the error :/ ... suddenly it works quite well... but I also updated to the latest bios lately (don't know if that had an impact) – enspandi Jul 9 '15 at 7:02
4

For the situation I described running a non-stock kernel, the following solution worked. Depending on what kernel series you're using, YMMV:

You'll need to do these to get grub/initramfs set up correctly:

sudo blkid | grep swap <-- get your swap uuid
sudo <your_text_editor_here> /etc/default/grub <-- edit your grub file    
GRUB_CMDLINE_LINUX="RESUME=UUID=<your_swap_uuid>" <-- add this to grub file
uname -r <-- get running kernel name
sudo update-initramfs -u -k <your_kernel_name> <-- init with the right kernel
sudo update-grub

Reboot, and then check for hibernate compatibility by doing pm-hibernate at the command line. Hope this helps someone else!

Not the answer you're looking for? Browse other questions tagged or ask your own question.