After upgrading my laptop from 14.10 to 15.04, the terminal wont' launch. Ctrl+Alt+T does nothing. neither will terminal run from dash. I tried launching gnome-terminal from xterm, but nothing happens. Running htop from xterm shows many instances of gnome-terminal. Any advice anyone?

  • 1
    Answering your own question is a thing here and it'll help mark this question as resolved.
    – Huey
    Jun 3, 2015 at 12:10
  • I guess that there is no answer to this question, except that Nautilus gnome is just poor quality. I have a hanging terminal at one user and not at an other, with both the same extremely simple .profile and no .bashrc . It is like having a decease and the doctor has nothing to go on except "I'm in pain". Albert Jan 24, 2019 at 11:34

8 Answers 8


I guess this is how you fix this.

You can change the locale in /etc/default/locale. You can try setting the contents of that file to:



Blog post

  • I find it infuriating that it just hangs without given even the slightest indication of what the heck is wrong. Albert Jan 24, 2019 at 11:30

OPs answer

Problem was a custom locale. Now using standard en_US.utf8 and gnome-terminal works normally.


I had the same issue upgrading to 15.04. I also went from 32-bit to 64-bit.

Just changing /etc/default/locale did not fix the issue.

Opening Language Support (in System Settings) and trying to change the default language gave the error that internationalisation was not fully installed. Clicking OK to install it gave an error.

The issue was that the boot partition (/boot) was full, blocking the download of the required packages. Search "cleaning the boot partition" for details - note that dpkg will not list all kernels from previous (32bit) versions so use the options to list what is installed in /boot.

After cleaning the boot partition, go into Language Support, change the default language, and accept the updates. That fixed the issue for me.


I have read a lot of advice about missing terminals, and it was frustrating when people gave me all these commands, which I cannot enter without my terminal...

Another frustration was not knowing that the terminal is properly called gnome-terminal in Ubuntu.

So to open a console, press Ctrl+Alt+F1 and you can log in to a text-only session.

Then try this command which will try to analyze and fix dependencies:

sudo apt-get build-dep gnome-terminal

With my present problem, it first asked me to put some source repos into my repository list. When I fixed that and repeated the build-dep command, it pointed out some 60 unresolved dependencies and offered to fix them, which I accepted.

For getting out of the console and back into your graphical environment, use Ctrl+Alt+F7.

There I found a message telling me to restart the computer which I did.

Either you will now have a working terminal or you might be several steps closer to a solution or at least you have received more information about your system and potential problem.

In my case I needed two more things:

I tried launching gnome-terminal from my console with this command:

/usr/bin/python3 /usr/bin/gnome-terminal

But I kept getting an error about not being able to connect to Mir (which supposedly is the name of a display server for Linux, being developed for Ubuntu, as a replacement for X11.

So first I entered this into my console:

export DISPLAY=:0

and again:

/usr/bin/python3 /usr/bin/gnome-terminal

When I returned to the GUI using Ctrl+Alt+F7, I found a running terminal!

I will still not launch directly from the GUI by clicking, but at least I know that all needed elements are now installed and I can do more research.

Hope that helps.

  • You don't need to export DISPLAY=:0, you don't have to use python, and you don't need to use the full pathname. You can just run DISPLAY=:0 gnome-terminal.
    – wjandrea
    Sep 30, 2016 at 20:03
  • Thank you wjandrea; I tried your command after a fresh boot and it works. Very nice, very helpful. Jan 21, 2017 at 19:05

It happened to me as well. Resetting desktop configuration to default solved my problem. Here's how you can reset it:-

dconf reset -f /


  1. https://www.omgubuntu.co.uk/2017/10/how-to-reset-ubuntu-desktop-to-default

I had the same problem after messing with the language configuration files. What did the trick for me was running

    dpkg-reconfigure locales

as root, and then selecting the languages I wanted to fix. Hope that helps.


I had the same issue after an upgrade of Debian Buster from 4.19.0-19-amd64 to 4.19.0-20-amd64 (March 2022) :

  1. once logged on, the system suggested me to translate my standard home subfolder names

  2. I couldn't open gnome-terminal (apparently due to a locales issue)

  3. there was no language available in the system settings (except US).

After reading some posts on the net (I don't remember where exactly...), like David said earlier in this thread, I did reconfigure locales with :

sudo dpkg-reconfigure locales

Obviously, as I didn't have gnome-terminal, I used CTRL-ALT-F3 (a terminal session), and CTRL-ALT-F2 to get back to gnome, for those who are unfamilliar with Linux...

I choose "all language", it took a few minutes, and all worked fine as usual (no need to reboot).

Hope it helps.


Nothing helps inspite of what I will be telling in the following lines: (Trust me I have tried all the methods) a) In case of xterm, the run command box says " command not found". b) In case of change in locale file, it says " you don't have permissions to do the same" ( in case you are not a sudo user )

-----Steps to follow are :

  1. Go to Settings.
  2. Go to Region and Language.
  3. Click on the Language option and then click on the three vertical dots.
  4. Automatically option with "English" will appear for you to select. If not, in search, type English and select the same.
  5. click ok and then it will say you to log-off.
  6. login again and Hurraahh! your problem is solved. Thank you for reading and I hope this helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .