30

Evidently, part of the upgrade to Ubuntu 15.04 involves an upgrade to gnome-terminal that removes the old feature that allows new terminal windows to be opened as a tab, instead of a new window.

If I had known this before the upgrade, I literally wouldn't have upgraded. Full stop. I manage many servers, and having an SSH client that allows new sessions in a tab is essential. Opening new windows for 15 servers is completely unmanageable.

In this screenshot, you can see the "open sessions" menu option. There used to also be an "open tab" menu option, with the complete list of sessions I have saved. It's gone now.

enter image description here

  • 10
    Ctrl+Shift+T or it doesn't work? Have you tried to search on the net? – Velkan Apr 24 '15 at 17:54
  • I can open the terminal program. It's gnome-terminal that's the problem. You can't "open session in new tab" like you used to be able to do. – Ernie Apr 24 '15 at 18:00
  • 6
    Ctrl+Shift+T, not Ctrl+Alt+T. – Velkan Apr 24 '15 at 18:02
  • 4
    Ctrl+Shift+T works for me... – Hitechcomputergeek May 23 '15 at 19:58
  • 2
    will be a nasty surprise to those who upgrade to 16.04 as well – prusswan Mar 19 '16 at 18:46
11

Just downgrade to good old 3.6.2 like me did.

If you have a 64-bit install:

wget http://archive.ubuntu.com/ubuntu/pool/main/g/gnome-terminal/gnome-terminal-data_3.6.2-0ubuntu1_all.deb http://archive.ubuntu.com/ubuntu/pool/main/g/gnome-terminal/gnome-terminal_3.6.2-0ubuntu1_amd64.deb
sudo dpkg -i gnome-terminal_3.6.2-0ubuntu1_amd64.deb gnome-terminal-data_3.6.2-0ubuntu1_all.deb
sudo apt-mark hold gnome-terminal
sudo apt-mark hold gnome-terminal-data

For 32-bit:

wget http://archive.ubuntu.com/ubuntu/pool/main/g/gnome-terminal/gnome-terminal-data_3.6.2-0ubuntu1_all.deb http://archive.ubuntu.com/ubuntu/pool/main/g/gnome-terminal/gnome-terminal_3.6.2-0ubuntu1_i386.deb
sudo dpkg -i gnome-terminal_3.6.2-0ubuntu1_i386.deb gnome-terminal-data_3.6.2-0ubuntu1_all.deb
sudo apt-mark hold gnome-terminal
sudo apt-mark hold gnome-terminal-data
  • 1
    Ugh. Why didn't I think of that? – Ernie May 13 '15 at 15:54
  • Is there a reason you can't use sudo apt-mark hold gnome-terminal gnome-terminal-data? – Hitechcomputergeek May 23 '15 at 20:15
42

If you want to know how to fix this problem, the new version has the option to open all new terminals in a tab. Go to Edit -> Preferences and then change "Open new terminals in: Window" to "Tab".

  • 7
    I feel like this should be the accepted answer. But omg did they mess up. – Andreas Mueller May 14 '15 at 18:43
  • 1
    It was the accepted answer, but it doesn't work very well. Going back to the older version is a much better solution. – Ernie May 14 '15 at 18:59
  • What didn't work for you? Not having the choice between tab and window in the menu? – Andreas Mueller May 14 '15 at 19:29
  • 1
    This new version doesn't let you specify the name of the tab, it only puts the current prompt into the tab's name. While that might be handy for some, having a prompt like ernied@hostname:/currentdir isn't particularly convenient when you have 12 tabs open, and every hostname only shows "ernie". There's ways around that too, but I find that prompt particularly helpful. Plus one of our servers wasn't even reporting the prompt at all. – Ernie May 15 '15 at 17:33
11

Downgrading kinda works but it isn't the best option since newer versions always have bug/security fixes.

The best option for you is installing mate-terminal, which is a regularly-updated fork of gnome-terminal that still has tabs and all of the bells and whistles you're accustomed to. I've got it running on my system now since gnome-terminal removed that tabs feature.

It's nearly identical but it's not missing features! Hooray!

Screencap of MATE terminal

  • Works great! Make sure to change the font to Ubuntu Mono so that it looks exactly the same as the Ubuntu Terminal. – 1'' Oct 11 '15 at 7:36
  • 1
    In addition, I had to run sudo update-alternatives --set x-terminal-emulator /usr/bin/mate-terminal.wrapper to make it default terminal. – geekQ Jun 11 '16 at 12:21
2

Try terminator for multi windows including broadcasting the same command to all open terminals...

sudo apt-get install terminator

http://gnometerminator.blogspot.co.uk/p/introduction.html

  • terminator may be nice, but cannot replace old good gnome terminal - it is way too different, hence not convenient as gnome terminal replacement; I am having similar issues after upgrade and also look for long-term solution... – bbonev Jul 19 '15 at 14:08
2

Use Ctrl + Shift + T to open 1st new tab. Subsequent tabs can be opened with the + button (in the gui, not the keyboard).

  • Ctrl+Shift+T works on my computer, but the + button does not open subsequent tabs. – karel Jul 5 '16 at 6:55
1

gnome-terminal is now so broken it is basically a bad joke. Profiles are difficult or impossible to manage, edit or delete.

If I ignore the recent transparency issues I got mate-terminal finally working by making my old profiles more accurate. Apparently mate-terminal now employs more stricter error checking mechanism and no longer work with undefined profile names ie. --tab-with-profile=Default only works in one profile (the first one.) Your next profile must be named differently (Default2 or for instance "Servers" like in my example below) and it must reflect in the new profile custom command.

example:

mate-terminal --tab-with-profile=Servers -t "server1" -e "ssh root@server1.domain.com -t screen -dRRS main"
--tab-with-profile=Servers -t "server2" -e "ssh root@server2.domain.com -t screen -dRRS main"

By using more precise Profile definitions and custom commands in mate-terminal I can ones again get all my profiles and 100 or so Tabs in good order up and re-connected with a click of a button :)

Gotto love the screen -dRRS main command. This allows you to reboot and return to your previous work with one click. All your terminal tabs will be exactly like you left them before you rebooted including the previous "on screen" command history.

-Sam

0
gnome-terminal --tab-with-profile=SOME_PROFILE_NAME -e 'ssh somehost'

or

gnome-terminal --tab-with-profile-internal-id=SOME_PROFILE_ID -e 'ssh somehost'

and Ctrl+Shift+Tstill works for me.

In contrast to 14.10 the default profile name is localised in 15.04.

  • That's fantastic, if I didn't just want to go File -> Open in Tab -> Session and felt like doing a whole lot of typing every time I open an SSH session for the 23rd time today. You know, like I did this morning. – Ernie Apr 24 '15 at 18:03
  • I can still open a new session from the list, but the other list for creating tabs no longer exists. – Ernie Apr 24 '15 at 18:09
  • In the preferences dialog you can change if you want new terminals to be opened as new window or as tab. – Florian Diesch Apr 24 '15 at 18:22
  • Yeah, I figured that one out on my own, ironically 3 minutes after you replied. – Ernie Apr 24 '15 at 18:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.