4

I just updated my laptop from Ubuntu 14.10 to Ubuntu 15.04. Now on a restart it fails to make it to the login prompt. The system looks to be in a cycle of failure and I see the message repeatedly

[ OK ] Started Light Display Manager.
[ OK ] Started ACPI event daemon.
       Starting ACPI event daemon...
       Starting Network Manager Script Dispatcher Service....
[ OK ] Started Network Manager Script Dispatcher Service.

The contents of /var/log/Xorg.0.log show a segfault. Sorry I can't copy the backtrace now, but the chain goes

/usr/bin/X
/usr/bin/X
/lib/x86_64-linux-gnu/libc.so.6
/lib/x86_64-linux-gnu/libc.so.6
/lib/x86_64-linux-gnu/libc.so.6
/usr/lib/x86_64-linux-gnu/xorg/extra-modules/nvidia_drv.so
/usr/lib/x86_64-linux-gnu/xorg/extra-modules/nvidia_drv.so
/usr/bin/X
/usr/bin/X
/lib/x86_64-linux-gnu/libc.so.6
/usr/bin/X
Segmentation fault at address 0x41

I'm on a Dell Precision m3800. Since the nVidia driver is implicated in the stack trace, I'll start with swapping that out.

Any suggestions for my next steps to try to fix this?

thanks, Dennis

  • 1
    We might have the same problem, look at this bug report: bugs.launchpad.net/ubuntu/+source/ubuntu-release-upgrader/+bug/… – Mondane Apr 24 '15 at 16:58
  • Thanks @Mondane So I tried booting into recovery mode and installing a different nvidia driver, but now my problem is that I can't get networking to function in recovery mode. It might be because the Dell Precision m3800 has a USB-to-ethernet adapter. Or it might be I don't know the arcane commands to get networking to work. I have spent several hours trying to get this to work and I'm close to just wiping the machine and installing fresh. I hate to do that because I'm going to lose a day of productivity. – dennisobrien Apr 25 '15 at 6:21
  • 1
    A similar question is askubuntu.com/questions/613577 . – JdeBP Apr 25 '15 at 9:28
6

I was able to fix this after reading the bug report @Mondane mentioned and several other troubleshooting articles on recovery mode.

  1. Boot into GRUB menu (pressing shift while starting).
  2. Choose recovery mode.
  3. Enable networking.
  4. Drop to root shell prompt.
  5. ifconfig eth0 and dhclient eth0 to get
  6. (Probably unnecessary) I had a some networking issues that were probably unrelated to this (undetermined so far) so I had to edit /etc/resolv.conf to include Google DNS 8.8.8.8 and 8.8.4.4.
  7. See what drivers are available for the nvidia hardware: ubuntu-drivers devices
  8. Install the recommended: apt-get install nvidia-346
  9. Reboot normally.
  10. Go to sleep.

Some resources I found useful:

For reasons I haven't yet determined, my networking was really messed up. I had to unplug and replub the USB-to-ethernet, run dhclient, then apt-get install nvidia-346 to get about 5% of the update before networking failed. This might be a hardware issue and totally unrelated, but it made troubleshooting and fixing this problem especially difficult.

  • This worked for me too. Dell XPS15 – Caustic Jun 3 '15 at 1:57
0

The Dell-provided USB 3.0 to Gigabit Ethernet adapter uses a Realtek chipset. When I updated to kernel 3.19, I had to fetch the latest r8152 driver from their site.

0

I found that the following works on mint 19:

choose recovery mode in grub, then resume to normal boot (this way you can skip the endless running job). Then in the normal desktop, switch nvidia driver.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.