8

Missing sound after updating form 14.10 to 15.04, installing "Ubuntu restricted extras" doesn’t help. Is there a way fix this or easy way to rollback to 14.10?

  • So, I’ve managed to shift my problem by adding the line options snd-hda-intel model=xxxx enable=1 index=0 to /etc/modprobe.d/alsa-base.conf, where xxxx is my soundcard from here. Now there is a headphones and line-out options in sound setting and it works after restart. But now there is sound from both speakers and headphones and i have to manually mute speakers when i plug headphones in. – Lucas Thaterminly Apr 26 '15 at 20:53
3

Try this: go to the terminal (Ctrl + Alt + T) and type sudo alsa force-reload, press ENTER. A password prompt is going to show up. Insert your password, and press ENTER. Wait for the process to end, reset all your programs and sound should be OK.

| improve this answer | |
  • Nope. The problem seems to be that it doesn't detect that there is headphones plugged in and i have to manually switch to headphones every time after restart. – Lucas Thaterminly Apr 25 '15 at 16:03
  • 1
    I tried everything, reinstalling alsa and pulse, M buttons :) but this force-reload did the work. Thank you very much :) – Xamidovic Aug 26 '15 at 6:18
2

Fixing that is simple, just install those two packages : alsa-base and pulseaudio You can do it with this command :

sudo apt-get install alsa-base
sudo apt-get install pulseaudio

If this doesn't work, please make sure you selected the right audio device in

System Settings > Sound
| improve this answer | |
  • 1
    Ok, i have alsa-base and pulseaudio. In sound settings there is only "digital output(S/PDIF)" option (i dont have s/pdif, just regular headphones). Switching from "Digital stereo output" to "Analog stereo output" in pulseaudio solves the problem, but i have to do it each time after restart. Is there a way to change default output device? – Lucas Thaterminly Apr 25 '15 at 15:18
  • I believe the behavior is to default to S/PDIF if you are plugged in with HDMI on boot. The idea is that if you have an external digital audio receiver, you probably want to use it, but if you're on the go, you don't want it selected by default. – Rich Remer Oct 29 '15 at 18:24
2

I also had the same issue after install 15.04. But managed to fix it by reinstalling Alsa and Pulse Audio. Also, I had to increase volume with Alsamixer.

This article explain everything nicely.

| improve this answer | |
  • 2
    Nope, made things worse for me. Sound volume icon disappeared from the menu bar and system settings window is now transparent. – Lucas Thaterminly Apr 30 '15 at 19:04
1

locate the .pulse folder in your home folder. Most probably its going to be under .config. Remove the .pulse folder. Logout and login. That should do the trick.

| improve this answer | |
1

I've seen this happen in two ways:

  • check in pulseaudio if you have multiple output sources that are not plugged in, and the wrong one is selected as primary. (go to configuration and turn everything you're not using off)
  • an application already binded to a specific sound source. Restart that application after doing the above

Volume Control Screenshot

| improve this answer | |
  • I just had this solution fix my problem. Any ideas why it chooses the wrong profile? – user541905 Sep 24 '16 at 5:59
  • well, I would guess something simple, like the motherboard giving the list of audio devices and listing out the undesired one first/with a lower device number. – fullmooninu Sep 26 '16 at 0:51

Not the answer you're looking for? Browse other questions tagged or ask your own question.