7

I have upgraded my System with full disk encryption from 14.10 to 15.04, and now i'm not able anymore to input my passphrase at boot and therefore can't access my system anymore.

Strangely it worked the first few times but today it suddenly stopped working. Also the keyboard is recognized in the BIOS and works in the GRUB menu.

Finally by taking out the hard disk from my computer and installing it in my laptop i am able to input the passphrase with the keyboard of my laptop.

I remember having this problem about one or two years ago, at this time the problem solved itself by a system update i installed by using my laptop.

Does anybody know a solution to this problem other than hoping a system update will fix it?

  • 1
    I have the same problem. For me it helped to boot using old kernel. – Tomasz Struczyński Apr 24 '15 at 10:42
  • this appears to be a bug (one of several) see post #45 here bugs.launchpad.net/ubuntu/+source/plymouth/+bug/1386005 to help determine exactly which one. – Elder Geek Apr 24 '15 at 17:00
  • I put my hard disk back in my main computer to try to boot using the old kernel, however just as suddenly as it stopped working it was working again. If it should reappear i will look into that bug. – dondaro Apr 25 '15 at 8:17
  • I have ubuntu 15.04, MSI MB and a razor usb key bored, and I have the same problem. After I get to the screen that alows me to put in my password it will not let me type anything. But if i restart my computer(CTRL+Alt+Del).... after the bios the screen goes purple then my key bored blacks out, when it comes back there is still nothing on the screen but purple. I then type my password in anyways and it always works. Its not working right but i can at least get into my computer so that's good. Hope this helps someone out there – user500706 Feb 2 '16 at 5:07
  • Try a different keyboard. Not all USB keyboards get properly recognized as an input device at this point in the boot process. For me the Logitech USB keyboard is only recognized as a Logitech Receiver. A different keyboard gets properly recognized as a full keyboard input device and you can enter the password. Once you get past this part then the Logitech keyboard will start functioning properly. Yes, The Logitech keyboard works fine during BIOS and GRUB menu. – fdk1342 Aug 31 '19 at 17:03
4

Ubuntu 15.04 release notes says Known Issues

It is not all good news however. Here are the known issues. All of which affect every Ubuntu flavour.

**You may not be able to enter your pass phrase if you use full disk encryption.
    LP: #1386005**
| improve this answer | |
5

I had this issue with 16.04.1. The workaround is to edit grub settings to use "nosplash" instead of "splash". (Note that simply removing "splash" does not fix the problem, at least in my case.)

From grub you can do this for the current boot by pressing e on the menu, and then searching for the line that says splash (should be close to the end), and then hit F10 to boot.

Instead of getting the graphical progress display and passphrase prompt you'll get a text-based prompt, and your keyboard should work. (On my machine I'll still occasionally get a blank screen instead of the prompt, but entering my passphrase at this screen still works, despite the lack of feedback.)

If this works for you, you can edit /etc/default/grub (again, change "splash" to "nosplash") and run update-grub.

Even with this setting, my machine (still running 16.04 LTS) will occasionally give me a blank screen (very dark gray, but slightly light lighter than the black of the BIOS startup) instead of the passphrase prompt. It turns out that you can still enter your passphrase at this point, though there will be no feedback unless you enter it correctly. (In my case, the drive light starts blinking, and the screen "unblanks" to continue the boot process.) This happens for about 25% of reboots. Thankfully, I don't reboot that often.

| improve this answer | |
3

I was struggling with this and in some page I saw something about this and drivers AMD... and then I remembered that when I installed Ubuntu on my fresh last install and use the full encryption all was working fine until I installed the AMD propietary drivers. So, I decided to switch from AMD drivers to Xorg and it just work. I don't know what does it have to do but it just work for me. I hope this works for you too.

| improve this answer | |
  • Likewise with nvidia-384 in 17.10. – banzaimonkey Dec 5 '17 at 18:07
2

It might be irrelevant but I had the same issue and for me what worked was I created an usb key for my FDE by following the directions here http://wejn.org/how-to-make-passwordless-cryptsetup.html and follow the setup here http://ubuntuforums.org/showthread.php?t=2197108&page=2&s=5a6803965cfacd8324f654aec5a03d97 then presto!!! Works with no issues. It will require you doing some homework first, but it works.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.