5

Since my update from Ubuntu 14.04 -> 14.10 -> 15.04 it sems that i cannot boot my system anymore as i am stuck at the password prompt when ubuntu appempts to mount my encrypted root partition.

The funny thing is, all USB devices are powered down after i left GRUB2's menu. Additionally there were other creepy sympthoms like: At first this only occurred when booting kernel 3.19. After some reboots, it didn't matter wich kernel i tried, nor did it matter if i started with systemd or upstart.

The most recent kernel i installed was linux-image-3.19.0-15-generic (not sure if the 0 and 15 are in their right places).

Also, when booting a kernel without the splash and vt handoff flags, i get the following error message, printed multiple times:

usb 1-3 device descriptor read/all, error -110

usb 1-3 device descriptor read/8, error -110

As i just noticed, when booting into recovery mode, the usb devices are powered up after one minute or so, but no input is still beeing accepted, not even pressing CAD has any effect.

I've tried 3 different keyboards for now, all USB2 to USB2 connectors.

I don't really know how to proceed with this. Any advice is welcomed.

6

Using a Logitech wireless? The 3.19 kernel used in 15.04 doesn't have built in support anymore.

Find a wired keyboard and log in. Edit /etc/initramfs-tools/modules and add

hid-logitech-hidpp

on a new line. Save and exit.

From the console run

sudo update-initramfs -u

reboot.

  • 2
    Nope, i'm using a wired keyboard and i cannot log in. – user1078701 Apr 24 '15 at 8:39
  • This was my problem though and fixed it for me. Thanks! – Cookie May 20 '15 at 11:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.