0

This is obviously easy to fix, I just want to understand it. I know Linux, but I'm not very familiar with Ubuntu.

gnome-terminal is getting environment variables that other terminals (xterm, rxvt-unicode, Linux console) are not. In particular, gnome-terminal gets http_proxy, https_proxy, ftp_proxy, all_proxy, and all caps versions of those. Those variables are not in /etc/profile, /etc/profile.d/*, /etc/environment.

  • 2
    What about /etc/bash.bashrc (assuming you use bash), and in your home directory, .bashrc, .profile, .bashrc, .bash_profile, .pam_environment etc.? – muru Apr 23 '15 at 23:51
  • Could it be due to gnome-terminal being default and others not ? Try changing the default terminal and see what happens – Sergiy Kolodyazhnyy Apr 24 '15 at 2:13
  • @jpkotta What other terminals don't have these variables set? Terminals in virtual consoles and SSH logins? Are they set in xterm? – Eliah Kagan Apr 24 '15 at 2:26
  • Did you do this perhaps? webupd8.org/2010/10/how-to-set-proxy-for-terminal-quick.html – Elder Geek Apr 24 '15 at 17:17
2

It is gnome-terminal itself that sets these variables. The relevant code resides in gnome-terminal's source, src/terminal-util.c, method terminal_util_add_proxy_env(). The values are taken from Gnome's settings, and the feature serves the purpose to have Gnome's proxy settings take effect on as many apps/utilities as possible, including console ones.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.