13

I upgraded my Dell Inspiron 7547 from Ubuntu 14.10 to Ubuntu 15.04 today, and I am now unable to connect to wireless networks.

I can see the wireless connection I am trying to connect to, but I am unable to connect. The connection times out without presenting an error message. First I tried forgetting the network and putting the information back in manually. I then tried disabling the wireless security on the router (Linksys E900) and reconnecting and had the same issue. I also tried connecting to a WiFi hotspot from my phone and had the same issue. The wireless connection from the router works fine on Windows 8.1 and my other wireless devices.

Any advice on what I should try next? What additional information can I provide to help?

Per comment, here is the output from running the wireless script: http://pastebin.ubuntu.com/10875310/

  • 1
    Just fyi, the version number is the date. 15 means 2015 and 04 means April. 15.4 is not the standard way it's written. Info from these wireless scripts can help troubleshoot. – grantbow Apr 23 '15 at 22:53
  • Thanks, Grant. I updated the version number and posted the results of running the wireless scripts. – Drew Andersen Apr 24 '15 at 0:54
  • 2
    Try deleting all connection settings through gui or manually in /etc/NetworkManager/system-connections folder. Restart network manager and try to reconnect – Sergiy Kolodyazhnyy Apr 24 '15 at 1:42
  • 1
    Lots more data to work from to help solve your issue! These two lines look interesting and might relate to your issue. parm: init_dbg:set to true to debug an ASSERT in INIT fw (default: false (bool) parm: power_scheme:power management scheme: 1-active, 2-balanced, 3-low power, default: 2 (int) – grantbow Apr 24 '15 at 3:31
  • 1
    No problem ! that the common thing to try first – Sergiy Kolodyazhnyy Apr 24 '15 at 4:29
17

I have been having similar issues (same wireless card). Here is what I did to fix it:

sudo service network-manager stop
gksudo gedit /etc/modprobe.d/iwlwifi.conf

Add options iwlwifi 11n_disable=1 to file, save, and close. Then:

sudo rmmod iwlmvm iwlwifi 
sudo modprobe iwlmvm iwlwifi 
sudo service network-manager restart

This will inactivate Wireless N so network speed may be affected.

If that doesn't work undo what you did by:

gksudo gedit /etc/modprobe.d/iwlwifi.conf

and delete the last line (options iwlwifi 11n_disable=1) and everything will be back to the way it was before.

  • 1
    This did the trick. Thanks so much! I'm not terribly concerned about the speed. What made you think to disable the Wireless N? – Drew Andersen Apr 24 '15 at 3:50
  • 1
    Also, there's a typo in the last bit of code. Should be 'modprobe.d'. – Drew Andersen Apr 24 '15 at 4:06
  • 2
    Seems to be the common fix for intel chipsets, if I am not mistaken. – Sergiy Kolodyazhnyy Apr 24 '15 at 4:28
  • 1
    Sorry about the typo, thanks for the catch. Should be good now (stupid dyslexia). As for the reason why, I've had issues in the past with intel wifi chips and this has fixed my issues in the past. Sorry that I cant provide a more technical answer. – Evan T Apr 24 '15 at 4:55
1

Evan's solution wasn't working. But, I have fixed the wifi issue by upgrading my linux kernel to 4.x as mentioned in the below post - Install Linux Kernel 4.0.3

  • Yeah this one worked. Fresh 15.04 installation on Intel i5 – Neil Aug 6 '15 at 9:28

protected by Community Apr 28 '15 at 23:21

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.