7

Today I installed Ubuntu 15.04 (desktop edition, 64 bit) on a DELL XPS 13 (model 9343) notebook. Prior to installation, I upgraded the computer bios to A03. The kernel I am running is 3.19.0-15. I have no audio/sound. Here is some info:

cribari@darwin4:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0

EDIT: the additional info of the comment

$ lspci -nn | grep -i audio
00:03.0 Audio device [0403]: Intel Corporation Broadwell-U Audio Controller [8086:160c] (rev 09)
00:1b.0 Audio device [0403]: Intel Corporation Wildcat Point-LP High DefinitionAudio Controller [8086:9ca0] (rev 03)
4
  • More info... lspci -nn | grep -i audio 00:03.0 Audio device [0403]: Intel Corporation Broadwell-U Audio Controller [8086:160c] (rev 09) 00:1b.0 Audio device [0403]: Intel Corporation Wildcat Point-LP High DefinitionAudio Controller [8086:9ca0] (rev 03)
    – jsbach
    Apr 24, 2015 at 0:33
  • I have the same problem than you :) Ubuntu 15.04 and Dell XPS 13 2015. My BIOS is also A03 and my kernel is 3.19.0-16 have you solved your problem ? My outputs are the same except that I also have card 1: PCH [HDA Intel PCH], device 0: ALC3263 Analog [ALC3263 Analog] Subdevices: 1/1 Subdevice #0: subdevice #0 for aplay -l. According to bartongeorge.net/2015/04/09/…, "All of the relevant patches have been backported and all functions will work out of the box." from April 15th on Ubuntu 15.04 but that's clearly not the case. May 18, 2015 at 9:07
  • According to wiki.archlinux.org/index.php/Dell_XPS_13_%282015%29, updating to Linux 4.0 could improve the situation and update to Linux 4.1 could make it even better but the wl-broadcom driver will not work. May 18, 2015 at 9:16
  • Please also add the output of dmesg -t | egrep "(audio|rt286|INT343)" May 18, 2015 at 9:52

1 Answer 1

10

The solution is here (thanks to Paul Wall).

First try to do 2 cold reboot in Ubuntu (cold reboot means that do need to shutdown and power up and not reboot!). If you still have no sound, try

sudo modprobe snd-soc-rt286

and then select the sound card in Systems Settings/Sound (for me, that worked).

If you want to have the module automatically load at start up, do

sudo nano /etc/modules

add this to the file

snd-soc-rt286

save and close it. Restart and your sound should be working without the need of sudo modprobe snd-soc-rt286. You will still need, however, to do a cold reboot after using Windows.

4
  • 2
    Just needed that "cold reboot"... thanks! :)
    – ngasull
    May 19, 2015 at 19:41
  • Two Cold Reboots fixed perfectly for me too!
    – Matt Mello
    Apr 7, 2017 at 19:42
  • The cold reboot did bring some sound, but the volume control doesn't work: it remains fixed at boot time... Jun 5, 2017 at 10:19
  • "Cold reboot" was the cure for me! Thanks!
    – madcorp
    Aug 12, 2017 at 8:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.