Nvidia: Xorg crashes on 15.04: "drmSetMaster failed: Invalid argument"

On a clean install of Ubuntu GNOME 15.04, I get the following screen after installing the Nvidia proprietary driver:

starting version 219
[  OK  ] Started ACPI event daemon.
                    Starting ACPI event daemon...

The last few lines from Xorg.0.log:

[     3.660] (II) intel(G0): [DRI2] Setup complete
[     3.660] (II) intel(G0): [DRI2]   DRI driver: i965
[     3.660] (II) intel(G0): [DRI2]   VDPAU driver: i965
[     3.660] (II) intel(G0): direct rendering: DRI2 enabled
[     3.660] (II) intel(G0): hardware support for Present enabled   
[     3.660] (EE) modeset(G1): drmSetMaster failed: Invalid argument
[     3.660] (EE) 
Fatal server error:
[     3.660] (EE) AddScreen/ScreenInit failed for gpu driver 1 -1
[     3.661] (EE) Server terminated with error (1). Closing log file.

(complete log here)

I tried all available proprietary Nvidia drivers.

System specifications:

  • OS: Ubuntu GNOME 15.04
  • CPU: Intel i5-3570K
  • GPU: NVIDIA GeForce GTX 660

How can this error be resolved?

  • 1
    @ViliusK: Disabling the Intel GPU in the BIOS/UEFI results in a proper boot, as does booting trough recovery mode (because the intel driver doesn't work in that situation). It's kind of a workaround, but worked in my case. – Silke Apr 24 '15 at 20:11

First I switched to a console (CTRL-ALT-F1). Then I removed all nvidia stuff with

sudo apt-get autoremove --purge nvidia-*

and reinstalled the nouveau driver using

sudo apt-get install --reinstall xserver-xorg-video-nouveu


sudo reboot

I know this is probably not what both of us want but it is still better than no desktop at all...

My Setup (for completeness):

  • OS: Ubuntu 15.04
  • CPU: Intel i5-4570S
  • GPU: Nvidia GeForce GT 610
  • 1
    Thanks for taking the time to answer this. Unfortunately the Nouveau driver is very crash-happy for me. As I said in another comment, disabling the Intel GPU completely solved the issue for me. I'll add an answer with some details about how to do this when I have some time to tinker. I've upvoted your answer as it is a workaround that might be satisfactory for people googling this issue. – Silke Apr 24 '15 at 20:16
  • This did notw ork for me. The system still crashes. The reinstall command did not work because the package was not found. – tokam Jul 18 '15 at 20:17

The 'solution' for me is disabling the Intel integrated GPU. There are two ways to go about this:


Disable the Intel GPU in your UEFI/BIOS settings. How to go about this differs per motherboard. For an Asrock Z77 Pro4 it meant setting:

Advanced > North Bridge Configuration > IGPU Multi-Monitor: Disabled

On other motherboards it can probably be found in a similar location.

Blacklist Kernel Driver

The other option is to blacklist the kernel driver (i1915), which is explained in this answer.
Edit /etc/modprobe.d/blacklist.conf and add: blacklist i915.

This can be done by switching to a TTY (ctrl+alt+f1), logging in and running:

echo "blacklist i915" | sudo tee --append /etc/modprobe.d/blacklist.conf

After rebooting, the Intel GPU will no longer work but the Nvidia GPU will work and (hopefully) Xorg will no longer crash.

  • Blacklisting is not possible on Optimus chipsets – GuySoft Feb 22 '16 at 13:28

Try to run nvidia-xconfig after nvidia drivers installation. Then reboot.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.