9

After an otherwise uneventful upgrade from 14.10 to 15.04 I cannot login. When I provide my password the screen flickers briefly and I am back at the login screen.

I have checked permissions on .Xauthority and they are set correctly.

I have also tried creating a new user, but the same problem persists.

Before reverting to the login screen I momentarily see an alert box "System program problem detected." I do not know if this is relevant to the issue.

My /var/log/lightdm/x-0.log contains this as the last line:

error setting MTRR (base = 0....) Invalid argument (22)
  • Get into a TTY and reinstall lightdm. – TheWanderer Apr 23 '15 at 18:38
  • Thanks, but that doesn't change anything, the problem persists. – mac Apr 23 '15 at 18:47
  • I'm glad you understood that. OK, try installing gdm. It might work better. – TheWanderer Apr 23 '15 at 19:10
  • Tried that in the mean time. That is even worse, with gdm I don't even get to a login screen, just black and some flicker every few seconds. – mac Apr 23 '15 at 19:14
  • See what happens when you login as guest. – TheWanderer Apr 23 '15 at 19:16
9

I fixed this problem by removing the nvidia drivers

sudo apt-get remove --purge nvidia-*
sudo apt-get install ubuntu-desktop
  • 1
    Tried that one too, with no luck. – mac Apr 24 '15 at 5:09
  • 1
    +1 from me, works. Reboot to ensure that the entire system knows the nvidia drivers are gone though. – dascandy May 2 '15 at 13:01
-1

You can try this first, here is a link. Ubuntu gets stuck in a login loop

If worse comes to worse you can remake the live USB. I would recommend Unetbootin as it really easily helps you to make it. The links for Unetbootin is here http://unetbootin.sourceforge.net/. And the one for Ubuntu is here .http://www.ubuntu.com/download/desktop.

When you go back with the new USB, you can reinstall cleanly for sure that way.

Hope this helps. Good Luck!

  • I recommend against Unetbootin. I used it to create a USB key for a Debian installation and the installation failed in weird ways although I tried several times in different ways. Not using Unetbootin immediately fixed the problem. – domsson Oct 25 '15 at 14:48
  • @domdom ---- You reccomend against Unetbootin because you tried it to create a USB key for a Debians installation and failed in weird ways. However, we are talking about Ubuntu here...I have used plenty of different programs for creating live USBs for Ubuntu and the on that I found both most efficient and easy to use... Unetbootin. I personally enjoy it as all the user is required to do is select the version of Linux they want from a drop-down menu and the rest is just left to time. This makes it very easy for users as they can leave their pc and return back later with it all finished :) – Apad121 Oct 26 '15 at 16:13

protected by Community Apr 26 '15 at 18:24

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.