8

I am trying to instlal OpenMPI on my Ubuntu 14.04 LTS following this guide

When I run the command sudo apt-get install -y autotools-dev g++ build-essential openmpi1.5-bin openmpi1.5-doc libopenmpi1.5-dev I get the error messages

E: Unable to locate package openmpi1.5-doc
E: Couldn't find any package by regex 'openmpi1.5-doc'
E: Unable to locate package libopenmpi1.5-dev~
E: Couldn't find any package by regex 'libopenmpi1.5-dev~'

Why is that? I tried on Ubuntu 12.04, there it worked fine.

marked as duplicate by Pandya, Eric Carvalho, Mitch May 3 '15 at 17:49

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • @Rinzwind I don't think I understand? Sorry, what do you mean.. – BillyJean Apr 23 '15 at 11:44
  • @Rinzwind I get the same error after adding universe – BillyJean Apr 23 '15 at 12:01
14

The version of openmpi in the 14.04 repository is 1.6. The packages you probably need to install openmpi-bin openmpi-doc libopenmpi-dev.

Generally, it's not recommended to install a specific release-numbered version of packages: there should be a package that always depends on the current version for the release, i.e.

$ apt-cache depends libopenmpi-dev
libopenmpi-dev
  Depends: libc6
  Depends: libopenmpi1.6
  Depends: openmpi-common
  Depends: libibverbs-dev
  Depends: libhwloc-dev
  Conflicts: libopenmpi-dev
  Conflicts: libopenmpi-dev:i386
  Conflicts: openmpi-bin
  Conflicts: openmpi-bin:i386
  Conflicts: 
  Conflicts: 
  Conflicts: libopenmpi-dev:i386

Not the answer you're looking for? Browse other questions tagged or ask your own question.