1

A note to readers: Yes, this question has already been asked. However, most of the questions asked about this topic never received an answer, and those questions that did receive an answer are grossly outdated and don't apply to the current versions of Ubuntu Touch. Circumstances have changed, therefore, this question is NOT a duplicate. Any off topic answers will be flagged.

I was reading up on the current Ubuntu daily builds yesterday, and I noticed that X86 support has officially been implemented into the current dev builds of Ubuntu touch. enter image description here This opens up a WHOLE bunch of new opportunities. I got to tinkering with an X86 emulator, using a modified Nexus 7 android bootloader in place of the traditional BIOS. I was able to get Ubuntu Touch running (slow as molasses, and not without the odd graphical issue), it was all going great, until U-T tried initializing the battery and the radio. It all crashed after that, even corrupted the image I was using to do it. However, this proves that Ubuntu Touch is capable of running on X86 hardware.

Now I'm pretty good with virtual hardware, but I suck when it comes to actually trying anything out on real hardware. I have no idea how to port an android bootloader to specific devices, much less attempting to manipulate Ubuntu touch into running on the disgraceful 32-bit UEFI firmware that comes with the majority of Windows (baytrail) tablets.

Honestly, getting an android bootloader to run in a virtual machine was bad enough, I had to create a virtual dynamic CPU that could switch between the ARM and x86 architecture inside of a running environment, without crashing, or even causing catastrophic damage to everything loaded in RAM.

So really, I just wanted to know if anyone had figured out how to get past these limitations, and in general, install Ubuntu Touch on a 32 or 64-bit Windows 8 tablet.

1
  • Try to download the newest image from Ubuntu Next. (This should be Unity8)

  • Then download and add bootia32.efi to .../EFI/boot/ on your install-USB-Stick to boot on that crappy 32-bit UEFI.

    This worked on my Pipo W1 Tablet, although touchscreen was not working and the wifi/blutooth driver also. Tried it on my desktop, worked but most apps crashed seconds after starting. :(

If it wont work with touch-ui (mir),

  • try to:

    sudo apt-get update
    sudo apt-get install unity8-lxc
    
  • reboot and then

    sudo unity8-lxc-setup
    
  • You can now choose the display manager at logging in. It runs in LXC-Mode, so the rest of the system should not be destroyed if something goes wrong (i hope XD).

EDIT: Also Touch is working on my Pipo W1, but i think it needs to be calibrated, i can not swipe in from the outside etc.

  • forgot that link: wiki.ubuntu.com/Unity8inLXC – nubnade Jul 7 '15 at 7:35
  • Thank you, my tablet is currently broken but I'm anxious to try out unity 8. I'll probably be using this method on my laptop for now. – john kieran Jul 9 '15 at 4:57
  • @nubnade - Broken link to Ubuntu Next – jmetz Oct 21 '16 at 12:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.