Could you help me out with a noob problem?

I used to be able to edit song properties in Rhythmbox (14.04) via generic user GUI stuff. Right click, hit edit properties, type what you need to, right? Approximately two months ago, whenever I hit 'Properties' on one of my songs to edit its properties, it won't let me delete the 'Unknown' placeholder so I can organize my music.

This has been a long-term issue that didn't occur in the past. This is getting to be quite annoying, and I would love it if someone would help me fix this. A list of commands or a package download would be helpful. Thank you.

Edit: Alright, I opened it from a terminal. I still cannot edit song properties. It's still glitchy. However, here's the feedback I got when I opened it from terminal.

r----e@r-----e:~$ rhythmbox

(rhythmbox:31606): Gtk-CRITICAL **: gtk_css_provider_load_from_path: assertion 'path != NULL' failed

(rhythmbox:31606): GLib-GObject-CRITICAL **: object SoupServer 0x872a148 finalized while still in-construction

(rhythmbox:31606): GLib-GObject-CRITICAL **: Custom constructor for class SoupServer returned NULL (which is invalid). Please use GInitable instead. Unable to open ~/.mtpz-data for reading, MTPZ disabled.

What does this mean? I'm still looking for help here.

  • So is the properties menu option available when you right-click - is it greyed out? What happens when you click the properties menu option? If you start rhythmbox from a terminal and then choose properties - does any error messages appear in a terminal? What type of music file are you trying to edit - e.g. mp3? mp4?
    – fossfreedom
    Apr 23, 2015 at 11:31
  • 1
    No, The properties box is still there. I just can't delete or type anything when I open it. I don't know what command to use to open it from a terminal. It's a .wav file, but the problem exists with all the other file types I've tried. Apr 23, 2015 at 19:13
  • just type rhythmbox from a terminal
    – fossfreedom
    Apr 23, 2015 at 20:59

1 Answer 1


It's probably a permissions problem. Try this:

chmod u+w /path/to/music/folder -R

If that's not the case, note that editing properties un *.wma files is not supported

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.