5

I've spent a ton of time searching for this on Google, and I still can't seem to find it. Please read fully before answering, because the majority of the answers I'm finding are about preventing screen-dimming while already logged in. I'm looking to prevent screen-dimming while on the lockscreen.

When I manually lock my screen, 5 seconds or so later, it dims to off. I don't want this behavior. I've set the display to never turn off in the GUI settings:

enter image description here

and from the terminal, I've tried all of the following:

gsettings set org.gnome.desktop.screensaver idle-activation-enabled false

gsettings set org.gnome.desktop.session idle-delay 0

gsettings set org.gnome.settings-daemon.plugins.power idle-dim false

I know this is possible, because I have done this before on 14.04. I recently reinstalled Ubuntu and of course forgot to document the change I made to make it do that.

One thing I do notice is that if I lock the screen, wait for it to start dimming, and then move my mouse around, it stays on. This tells me there is some function that starts a countdown immediately after you lock the screen, and then dims the screen once it runs out. I'm trying to figure out how to disable that.

I am running a fully updated copy of 64-bit Ubuntu 14.04.2 on a Lenovo T540p.

Any ideas would be really helpful.

0

Ubuntu 16.04

I have also been trying to figure out how to stop the lock screen from dimming. I can not seem to find anything associated with the screen dimming when going to the lock screen that I can edit/tweak.

I tried all the usual suggestions of

gsettings set org.gnome.desktop.screensaver idle-activation-enabled false

gsettings set org.gnome.desktop.session idle-delay 0

gsettings set org.gnome.settings-daemon.plugins.power idle-dim false

but none of them worked.

**** WORKAROUND ****

However invoking an activity once the dimming starts seems to then follow what ever settings you have enabled in the system settings > Brightness & Lock > settings.

The way you can stop it is by locking the screen then typing a few random characters into the password prompt. It will now no longer dim.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.