2

I have installed Ubuntu 14.04 LTS 64-Bit and have a Edimax EW-7811Un wifi adapter. I have tired to get it to work but have no luck.

when I run lsusb command I get:

Bus 001 Device 005: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]

iwconfig shows that nothing is being read or connected:

eth0      no wireless extensions.
lo        no wireless extensions.

I have tired numerous forums and tutorials but cant get it to work, dont know what I am doing wrong.

Can someone give a clear step by step method to get this to work?

uname -r: (Kernel Version)

3.16.0-34-generic
6

This has been reported to work:

sudo apt-get install linux-headers-generic build-essential dkms
git clone https://github.com/pvaret/rtl8192cu-fixes.git
sudo dkms add ./rtl8192cu-fixes
sudo dkms install 8192cu/1.10
sudo depmod -a
sudo cp ./rtl8192cu-fixes/blacklist-native-rtl8192.conf /etc/modprobe.d/

Reboot

(Source)

6
  • PERFECT!!! Thank you mate, been searching long and hard for this. – harnamc Apr 22 '15 at 22:34
  • Should I be worried about all the failed attempts and random drivers I have tried to download and install? Is there a way to clean/flush them? – harnamc Apr 22 '15 at 22:36
  • This likely replaced all that since it worked – Jeremy31 Apr 22 '15 at 23:12
  • Under Ubuntu 14.04 LTS the adaptor seems to be supported but the connection is intermittent. For anyone facing this problem while applying this patch, I recommend just disconnecting and re-connecting to the Wifi hotspot. – Andy J Jan 3 '16 at 5:56
  • how do we undo this - i did this and found that it did not support 5GHz. My internal realtek8723be works just fine too (i manually built and installed rtlwifi_new). So i want to go back to that. Presently after this, when i take out the edimax usb, i dont even get the enable-wifi listed. So how to undo this ? – ustulation May 19 '16 at 18:14
0

Ubuntu makes newer kernels (and X Windows) available to the LTS releases, called the LTS Enablement Stack. I installed the latest kernel on my 14.04 (Trusty) system, which at the time of writing is the kernel for Xenial (16.04). Newer kernels have newer drivers and firmware.

sudo apt-get install --install-recommends linux-generic-lts-xenial

Then reboot to upgrade to the Xenial kernel. On my system, the Edimax adapter worked fine afterward.

-1

The drivers from https://www.edimax.com/edimax/download/download/data/edimax/global/download/for_home/wireless_adapters/wireless_adapters_n150/ew-7811un didn't work for me on 20.04. The make file was giving me errors.

After some time searching I found https://github.com/SonelSA/rtl8723bu_realtek which fixed it for me.

To install:

git clone https://github.com/SonelSA/rtl8723bu_realtek
make
sudo make install
sudo modprobe -v 8723bu
1
  • 2
    RTL8723BU and RTL8723CUS are different devices. – Pilot6 Jan 10 at 18:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.