1

When I run the 'sensors' command in terminal, I get this:

acpitz-virtual-0
Adapter: Virtual device
temp1:        +55.0°C  (crit = +200.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +70.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:         +70.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:         +74.0°C  (high = +100.0°C, crit = +100.0°C)

thinkpad-isa-0000
Adapter: ISA adapter
fan1:           0 RPM

My /etc/thinkfan.conf settings are the following

sensor /sys/devices/platform/coretemp.0/hwmon/hwmon2/temp3_input
sensor /sys/devices/platform/coretemp.0/hwmon/hwmon2/temp1_input
sensor /sys/devices/platform/coretemp.0/hwmon/hwmon2/temp2_input

(0,     0,      55)
(1,     48,     60)
(2,     50,     61)
(3,     52,     63)
(4,     56,     65)
(5,     59,     66)
(7,     63,     32767)

My settings in /etc/modprobe.d/thinkfan.conf are the following:

options thinkpad_acpi fan_control=1

Shouldn't that mean that the fan should turn on at 55 degrees?

I have also tried running the following in terminal.

# echo level 7 > /proc/acpi/ibm/fan 

One tutorial suggested that this would turn on the fan automatically, but nothing happened for me.

Are there any other settings that I should configure?

1

What solved it for me was to, in BIOS, change the Thermal Management setting from Optimal Performance to Balanced.

  • Thanks. This enables the fan but the problem is not really solved as now the CPU is throttled more. This seems to be a linux specific problem as on windows the fan also works in "Optimal Performance" mode. – fivef Jul 13 '16 at 13:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.