3

My lock screen shows up after a few minutes in which I am not using the computer. This is a wanted behaviour. However, it often switches the input language to Hebrew, or perhaps just taking the last chosen input language.

In almost 100% of the times, I find myself trying to log in Hebrew, failing, and then logging in again in English. This is annoying.

Moreover, unlike in Ubuntu 12.04, in my current Ubuntu 14.04 I don't see in the password input field any sign that this is Hebrew that I enter now - only in the corner of the screen. It still types from left to right, as if it was English.

Can I somehow force the lock page to choose English by default..? Perhaps by some hook?

  • The login screen shows up? Don't you mean the lock screen? Those two components are managed by two different pieces of software. – s3lph Apr 22 '15 at 15:35
  • 1
    I think it's the lock screen you are talking about, as @the_Seppi said. Possibly you hit bug #1286910. – Gunnar Hjalmarsson Apr 22 '15 at 16:45
  • @GunnarHjalmarsson, you're probably right. Do you wish to post it as an answer so we can close this question? – Bach Apr 24 '15 at 7:44
  • Sure, just did. – Gunnar Hjalmarsson Apr 24 '15 at 19:48
  • ... and a moderator deleted it ... – Gunnar Hjalmarsson Apr 25 '15 at 15:16
2

I think you hit bug #1286910.

George Karakostas has reported there that Martin Jurča's workaround to bug 1240198 worked for this bug also.

Here's an easy fix:

  1. open terminal
  2. run ibus-setup
  3. open the extra settings (the last tab)
  4. check the "use system keyboard layout" checkbox

Now, how about you guys (yes, you, Canonical) make this the default settings? All I know about it is that it (probably) stores its config in gconf, but I cannot find it, so I cannot give you a patch.

So you should attempt that fix for your problem, too. (Note, however, that Mikhail V. Golubev has reported this workaround did not work in his case. So this is apparently a usable solution only for some instances of this problem.)

  • This popped in the low-quality queue. The bug report comments suggest a possible solution, so could you add that as well to fill out this answer? – muru Apr 24 '15 at 21:45
  • @muru: Originally it was just a comment, but I made it an answer since the OP asked me to. I don't know enough about the topic to advocate a solution/workaround. – Gunnar Hjalmarsson Apr 24 '15 at 22:01
0

If you are using lightdm when you face this problem:

  1. Press Alt+F2 (or F1 ... F7)
  2. Enter your account username and password and go to the terminal
  3. Enter sudo service lightdm restart

Then you will be redirected to another main lock page whose language is English by default.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.