1

After a recent software update (possible to kernel 3.13.0-49), Ubuntu Trusty no longer displaying Launcher & top status bar properly on a very old Dell using 32 bit Ubuntu Trusty. I used to use xorg-edgers ppa on it but I took it off about a year ago while back when it was no longer needed as Trusty did the display properly (or it might have been as it no longer worked properly). I've tried putting the ppa back again & upgrading but still the same. Also, the mouse cursor moves but clicking it on an icon's area does not work. Unfortunately I used Ubuntu Tweak to remove old Linux stuff. Any ideas?

  • try to simply reinstall it sudo apt-get install --reinstall ubuntu-desktop unity then re-login. – JoKeR Apr 22 '15 at 13:49
  • The reinstall worked OK. I noticed that the packages have a date 20150315 as part of their 'name'. But still no good on the Launcher or the mouse. – John Rose Apr 22 '15 at 14:10
  • what you mean by no good I won't understand you should at least attach a screenshot or something like that. – JoKeR Apr 22 '15 at 14:27
  • By 'no good' I meant that the Launcher stayed the same i.e. I can see the places for the icons but they do not contain pictures but contain out-of-focus white & grey sort of images. I can't take a screenshot of the Ubuntu screen showing the messed-up Launcher as the Dash doesn't work: after clicking on the Dash (corrupted) icon it displays for input but won't accept it and returns to the login screen. I have no printer attached to the PC so PrtScreen does nothing. Even if I could take a screenshot how would I attach it to this comment? – John Rose Apr 22 '15 at 14:58
  • printer has nothing to do with PrintScreen button you just take a screenshot and upload it to any file server like e.g. imgur.com and post a link to it here – JoKeR Apr 22 '15 at 19:39
1

I suspect the problem could be a quirk in your video card.

I have a older Dell (approximately 9 years old) that I bought used, and on which I have run Ubuntu exclusively for quite a few years. Starting with Ubuntu 12.04 I found the Unity Dash was unusable. (When I clicked the Dash button, the screen would flicker but none of the Dash overlay would appear on the screen, so there was no way to select any icon in the Dash at all.) Back in 12.04 you could login using Unity 2D, which avoided the bug in the video card's firmware. By the time 14.04 was released, Unity 2D was gone, so I knew I wouldn't be able to upgrade my machine if I wanted to use "stock" Ubuntu.

SO I copied Ubuntu 14.04 to a USB stick and carried the machine to a local computer repair shop and asked them for a cheap generic video card (using a different chipset, just to be sure). The folks at the shop installed their video card and I booted from the USB stick to test it. I rejected a bad one, but ultimately got a working card that works fine, and the replacement cost me very little.

Another even cheaper option (if your Dell system works this way) might be to try the Intel video built into the motherboard. On my system, I have to remove a plastic cap blocking the video port and also activate the onboard video in the BIOS.

Nowadays the limited RAM in my old machine (4 GB maximum) has begun to become more of an issue with modern RAM-hungry applications, and there's not as easy a workaround... except that your local computer shop might sell you a four- or five-year-old machine with a more modern upgradeable motherboard and processor.

  • Looks like it's the graphics card. machine is so slow that I'm scrapping it. – John Rose Apr 23 '15 at 11:40
  • If you believe the card is the problem, you could mark this answer as the solution. If you want to identify exactly which card you have, see How Do I Find Out the Model of My Graphics Card – Tommy Trussell Apr 24 '15 at 16:47
  • I would mark this as the solution if I knew how to do it. – John Rose Apr 25 '15 at 6:37
  • At thevtop left of each answer, there's an up-arrow for marking your approval of the answer. If the answer is in reply to your question, there's an additional button for saying it's the answer. (There are additional buttons and arrows around the questions and answers as well.) – Tommy Trussell Apr 26 '15 at 12:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.