7

I am trying to update HPLIP 3.14.3 to 3.15 but is not available through the software centre thus I am installing it from here.

However I am having difficulties in the automatic installation due to python. In particular, after selecting ubuntu 14.04, I get the error:

warning: Missing REQUIRED dependency: python3-dbus (Python DBus - Python bindings for DBus) 
warning: This installer cannot install 'python3-dbus' for your distro/OS and/or version. 

But I have installed the following:

python
IDLE python 3.4
python 3.4
python3-dbus 1.2.0-2build2 (but not D-bus support & debug)

And when I tried to update these option I got:

Requires installation of untrusted packages

How can I overcome this issue? Thank you

best regards

Gigiux

2

I have run across this same issue with a newer HP printer and HPLIP. What eventually worked for me was an updated version of CUPS. At the time, I had to manually compile however it may be updated in the latest beta (15.04). I wouldn't recommend upgrading right away without question... first try a live nightly version to see if it will work or not.

  • Dear Kent,\n thank you for the reply, but this raises the issue of updating CUPS. When adding a new printer with CUPS, officejet 5740 FAX is correctly identified, but in the ADD PRINTER page there is no the proper printer name thus no installation. .. – Gigiux Apr 27 '15 at 21:07
2

I saw the same error message and it turned out that a custom Python installation was active (using virtualenv).

apt-get install installed these packages into the system's Python installation, but HPLIP ran in a shell where another Python installation was active. You can check this by trying to import dbus in Python, executed in the same shell as HPLIP:

$ python
Python 3.4.0 (default, Nov 21 2015, 10:48:18) 
[GCC 4.8.4] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import dbus
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: No module named 'dbus'

$ which python
/home/me/custom/python/dir
  • 1
    I also had quite a lot of trouble with these kinds of errors (missing REQUIRED dependencies), and had anaconda installed. Removing it from my path and launching a new terminal for executing the installation script resolved that for me. – Steve Kroon Mar 16 '16 at 20:26
1

I spent so much time on this issue an thanks to hcs42 and Steve Kroon I finally solved this. So I'd like to summarize how I solved the problem for me:

I have Anaconda installed:

>> python
Python 3.6.6 |Anaconda custom (64-bit)| (default, Jun 28 2018, 17:14:51)
...

I now opened /home/USERNAME/.bashrc

Here I found the following lines:

# added by Anaconda3 installer
export PATH="/home/slu/anaconda3/bin:$PATH"
# added by Anaconda3 installer
export PATH="/home/slu/anaconda3/bin:$PATH"

I changed them to:

# added by Anaconda3 installer
# export PATH="/home/slu/anaconda3/bin:$PATH"
# added by Anaconda3 installer
# export PATH="/home/slu/anaconda3/bin:$PATH"

I verified using a new terminal:

python
>> Python 2.7.13 (default, Sep 26 2018, 18:42:22)
...

Now I could simply run:

bash hplip-3.18.12.run

This allowed me (using automatic installation mode) to set up my printer being able to print and scan.

(Don't forget to uncomment the exported path in .bashrc)

Thank you again hcs42 and Steve Kroon. This really helped me!

0

Try : pip3 install dbus-python

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.