5

I'm having issues trying to install Ubuntu side by side with OS X on a 2015 MacBook Pro 13" model with Retina. I have the MacBook12,1 model. When I attempt to run the installer, I see the usual GUI but every window contains no text. I've tried both USB and CDs as a means of installing Ubuntu with the same results. I have the same symptoms when I run the trial version as well. Is there a compatibility issue with the newer MacBooks and 14.04 and 14.10 versions when it comes to fonts? I've tried Googling and searched several forums but it seems I can't find anyone with this problem. I've never seen this before installing Ubuntu an any machine. Any help is appreciated. :)

enter image description here

  • @Ryan can you take a picture of the screen and upload it, it might help. – Mateo Apr 22 '15 at 0:51
  • Sure thing. I'm at work right now but I'll include a screen shot later today. – Ryan Mesa Apr 22 '15 at 19:04
  • Hello, sorry for the delay, but I've been swamped lately. What's the best way to attach a screenshot to a comment? I'm looking around this page and I don't see a link or any way I can paste the image. – Ryan Mesa Apr 24 '15 at 18:21
  • I used to dropbox to share the image so hopefully this link works. Please let me know if you can see this... dropbox.com/s/lh4w3q8mojpyi9m/IMG_0180.JPG?dl=0 – Ryan Mesa Apr 24 '15 at 18:43
  • Cool, got it in there. – Mateo Apr 24 '15 at 21:26
0

For what it's worth, I had the exact same thing happen to me when installing 15.04 on my desktop. No text on the GUI installer. It was really annoying to figure out what was going wrong.

Turns out the noveau driver was doing weird things so I had to manually append "nomodeset" in the boot options.

Solution:

  1. Hit Spacebar on first purple screen when booting from the installer. This will take you to some extra installer options.
  2. Highlight "Install Ubuntu" by using your arrow keys.
  3. Add "nomodeset" to the Boot options command line (I added it at the end before the "--")
  4. Hit Enter to start the installer without mode setting.

If this worked you should see the Ubuntu splash screen start in a low-res mode.

NOTE: I had to manually append "nomodeset". There is an F6 menu that can select nomodeset too but that did not work for me.

1

I tried version 15.04 and all appears to be well now. I suppose that 14.04 and 14.10 is not entirely compatible with the latest MacBook models.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.