1

When running following command:

setquota -ua username 4718592 5242880 0 0

I get this error:

setquota: Cannot set quota for user 1002 from kernel on /dev/mapper/hostname--vg-root: Numerical result out of range

The command is called by a script on a webserver, which manages the users (websites). This system has been used for the last year without any problems. There are 183 users, which have set quotas (15gb each). I was thinking that the cause might were the sum of the quotas that exceeded the space on the disk, but its around 240gb, so the problem should have started at a lower usercount.

I have tried to set quotas on one of the users to just a little more space than he's using atm, but I got the same error.

What to do?

Thanks in advance

0

I know it is an antediluvian question but I stumbled on the same problem recently and here is the solution that worked for me.
For large quotas (for me >4Tb) one needs to use the 64 bits format of quotas vfsv1:

In /etc/fstab after "defaults" or whatever options you already set, insert:
grpjquota=quota.group,usrjquota=quota.user,jqfmt=vfsv1

Then:
$ sudo mount -o remount /home
$ quotacheck -cug -F vfsv1 /home

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.