I'm trying to backup my whole HDD by using the following script:

rsync -vaxE --progress --delete --log-file='./rsync-log' / /media/me/Backup/

It works as expected except for one thing - it copies /home but ignores anything inside it, leaving it empty at the destination. At the same time every other directory is getting synced recursively just fine.

here's log where you can see how it traverses other directories, but not /home.

2015/04/21 17:05:42 [23304] .d...pog... etc/xfce4/
2015/04/21 17:05:42 [23304] .d...pog... etc/xml/
2015/04/21 17:05:42 [23304] .d...pog... etc/xsp4/
2015/04/21 17:05:42 [23304] .d...pog... etc/xsp4/conf.d/
2015/04/21 17:05:42 [23304] .d...pog... etc/xul-ext/
2015/04/21 17:05:42 [23304] .d...pog... home/
2015/04/21 17:05:42 [23304] .d...pog... lib/
2015/04/21 17:05:42 [23304] .d...pog... lib/apparmor/
2015/04/21 17:05:42 [23304] .d...pog... lib/brltty/

Google didn't help. What am I missing?


You are using the -x option, so I'm going to guess /home is on a separate partition. From man rsync:

-x, --one-file-system       don't cross filesystem boundaries

First you have to execlude .gvfs if GVFS is installed.

rsync -vaxE --progress --delete --log-file='./rsync-log' --exclude={"/home/*/.gvfs"} / /media/me/Backup/

Or if you use /home as separate partition then remove -x option

rsync -vaE --progress --delete --log-file='./rsync-log' --exclude={"/home/*/.gvfs"} / /media/me/Backup/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.