1

First of all after installation of Ubuntu 14.04 I was having problem - system freezes after few minutes of work.

I installed nvidia-current driver, it helped. I decided to install something more newer(I want to use GPU calculation with CUDA, finally).

I tried "additional drivers" 331. Didn't worked. Black screen after rebooting. I tried to install Nvidia drivers from offical site(last one, 346).

Also black screen or blank. Tried Xorg drivers - recommended 349 and 346. Same...Black screen.

I have GTX 590. I completely new to Linux, so getting lost in it. Why is it happening, whom drivers I should use and how to get it work?

2

I had the exact same problem and I solved it like this (Actually Raphael solved) like this:

  • First find out which Graphic Card you are using (Exact model)

    You can contact the manufacturer or lspci and search for 3D controller .

  • Go to Official Nvidia website and Manually find drivers for your NVIDIA products

  • And Select appropriate version of Linux (64bit or 32bit)

  • Search

  • Now know your driver number (ex : Version: 352.63 )(No need to download the *.run file just know the version)

  • Switch to your default driver in Additional Drivers:

    enter image description here

  • Now in terminal (Ctrl+Alt+T) run this command to remove all previous installations of Nvidia Drivers:

    sudo apt-get remove --purge nvidia* Enter

  • Add this repository : sudo add-apt-repository ppa:graphics-drivers/ppa -y

  • sudo apt-get update

  • sudo apt-get install nvidia-352 REPLACE 352 WITH YOUR LATEST DRIVER VERSION from Nvidia(don't worry about the decimals 352.xx => 352)

  • Reboot after the installation is complete.

This worked well for me : I am using Nvidia GeForce 820M.

1

Open Software & Updates app in Ubuntu and it allows to install NVIDIA driver from GUI.

0

Download Nvidia driver from http://www.geforce.com/drivers

To install the driver from source:

Disable nouveau

  1. open any tty other than GUI by ctrl+alt+f[1-6]
  2. stop lightdm/gdm or whatever is your display manager

    sudo stop lightdm

  3. run the script

    sudo sh NVIDIA----.sh

solving problems

  1. if something goes wrong close the installer and reboot then try again
  2. still same problem the nvidia installer will make a black list in /etc/modprobe.d/
  3. if this is not generated you have to make such file to black list nouveau
  4. Run sudoedit /etc/modprobe.d/nvidia-graphics-drivers.conf and fill it with this:

    blacklist nouveau

  5. If the problem is not solve you have to add the string "nomodeset" to your /etc/default/grub, in GRUB_CMDLINE_LINUX_DEFAULT= line

  6. then update the grub

    sudo update-grub

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.