1

This old bug affects me severely, I say old bug because it is very well documented in the following link: Bug report

This bug results in two things:

My on-board networking doesn't work, and trying to restart or shut-down the computer freezes the system.

So, if you read the bug report you noticed there is a fix, well I have actually successfully fixed the issue two times, but it keeps coming back after reboot, and now I can't seem to fix it.

Fix that worked:

  • Added forcedeth msi=0 msix=0 to /etc/modules
  • Added exec rmmod forcedeth directly underneath the beginning of the script section in the file /etc/init/kmod.conf (I can't find a module-init-tools.conf, is the kmod.conf the equivalent?)
  • Added modprobe forcedeth msi=0 msix=0 to /etc/rc.local

It seems like I’m very close to solving this problem that affects my machine so much, but at the same time I’m lost because I don’t understand the way the modules and the forcedeth works.

content of modprobe.d:

alsa-base.conf              blacklist-modem.conf         iwlwifi.conf
blacklist-ath_pci.conf      blacklist-oss.conf           mlx4.conf
blacklist.conf              blacklist-rare-network.conf  modesetting.conf
blacklist-firewire.conf     blacklist-watchdog.conf      vmwgfx-fbdev.conf
blacklist-framebuffer.conf  fbdev-blacklist.conf
  • possible duplicate of Prevent gedit from creating files with the '~' (tilde) suffix – mikewhatever Apr 21 '15 at 14:35
  • "a duplicate emerges with the same name as the file I modified but with a ~ at the end of the file," That is due to you using gedit and you have it set to create a backup/copy. Removed it since it had nothing to do with a problem. – Rinzwind Apr 21 '15 at 14:35
  • Thanks for the edit, the gedit backups were throwing me off but you are totally right, it has nothing to do. The issue is about the kmod.conf file and the module-init-tools.conf - How to run the forcedeth commands/module ? – Julian Uribe Apr 21 '15 at 14:42
  • You shouldn't have to exec rmmod forcedeth with forcedeth msi=0 msix=0 added to /etc/modules – Elder Geek Apr 21 '15 at 15:07
2

I suggest you remove all the instances you mention above. The correct way is:

sudo -i
echo "options forcedeth msi=0 msix=0"  >  /etc/modprobe.d/forcedeth.conf
exit

Upon reboot, the parameters will be applied. Whether they fix your exact issue is another question.

  • I followed your instructions and rebooted and its working perfectly, I hope this is a permanent fix. I will wait until the next reboot before I claim victory. Thank you very much! – Julian Uribe Apr 21 '15 at 14:56
  • Rebooted and it kept working, Thank you so much chili555, your suggestion was the last little piece of help I needed to get my computer working properly. I hope this old bug gets fixed because it stole me many hours. Thank you!!!! – Julian Uribe Apr 21 '15 at 15:13
  • Does not work for me, still not able to get any internet connection through my ethernet wire... Any other ideas? – Nyxynyx Apr 2 '16 at 22:49
  • @Nyxynyx Please start your own new question and be sure to include: lspci -nnk | grep 0200 -A2 Thanks. – chili555 Apr 2 '16 at 23:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.