when i trying to ran qt-linux-opensource-5.0.2-x86-offline.run I gets below error.

./qt-linux-opensource-5.0.2-x86-offline.run: error while loading shared libraries: libSM.so.6: cannot open shared object file: No such file or directory

I have installed Qt before but I didn't get any error. I think the cause should below command

sudo apt-get autoremove

I ran this command to my newly installed ubuntu. I found this article online

http://docs.alfresco.com/5.0/concepts/install-lolibfiles.html

so I ran below command

sudo apt-get install libice6 libsm6 libxt6 libxrender1 libfontconfig1 libcups2

but terminal says its already installed

libsm6 is already the newest version

can anyone tell me a way to install qt creater

  • post the output of apt-cache policy libsm6 – A.B. Apr 21 '15 at 8:23
  • libsm6: Installed: 2:1.2.1-2 Candidate: 2:1.2.1-2 Version table: *** 2:1.2.1-2 0 500 lk.archive.ubuntu.com/ubuntu trusty/main amd64 Packages 100 /var/lib/dpkg/status – Menuka Ishan Apr 21 '15 at 12:40
  • and ldconfig -p | grep libSM.so.6? – A.B. Apr 21 '15 at 12:44
  • libSM.so.6 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libSM.so.6 – Menuka Ishan Apr 21 '15 at 12:50
up vote 14 down vote accepted

libSM.so.6 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libSM.so.6

The program requires 32-bit libraries. You need libsm6:i386

sudo apt-get install libsm6:i386

And now, ldconfig -p | grep libSM.so.6 should look like this:

libSM.so.6 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libSM.so.6
libSM.so.6 (libc6) => /usr/lib/i386-linux-gnu/libSM.so.6

And for all other missing libraries use the same strategy:

e.g. libXrender.so.1

$ apt-file search libXrender.so.1
libxrender1: /usr/lib/x86_64-linux-gnu/libXrender.so.1
libxrender1: /usr/lib/x86_64-linux-gnu/libXrender.so.1.3.0
libxrender1-dbg: /usr/lib/debug/usr/lib/x86_64-linux-gnu/libXrender.so.1.3.0

$ sudo apt-get install libxrender1:i386
  • Now I'm getting new error ./qt-linux-opensource-5.0.2-x86-offline.run: error while loading shared libraries: libXrender.so.1: cannot open shared object file: No such file or directory – Menuka Ishan Apr 21 '15 at 13:07
  • I have improved my answer. :) – A.B. Apr 21 '15 at 13:10
  • I saw it later :) I found about this command sudo apt-get install qtcreator It installed the qtcreator but I'm worried because terminal said size is 100 MB or something but offline installer 465 MB. What is different between them? – Menuka Ishan Apr 21 '15 at 16:19
  • @MenukaIshan I can not answer satisfactorily you. Without the right to look at, I can only guess. – A.B. Apr 21 '15 at 16:45
  • @MenukaIshan Were you satisfied with my answer? Then give me a upvote (∧). If I could solve your problem, then it would be nice if you'd mark my answer (✓). ;) – A.B. Apr 21 '15 at 16:45

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.