1

I just installed the updates (sudo aptitude upgrade, not dist-upgrade!) on a computer that is usually not connected to the internet. It uses Xubuntu 14.04.2 LTS (trusty) with an ATI Radeon HD 6550D video card and the fglrx-updates driver.

During installation of the updates, it asked me if I want new configuration files or if I wanted to keep the old ones. I choose to keep the old ones just to be sure. After rebooting however, my screen resolution is stuck at 640x480. It can't be changed from the list in the Display settings.

So my question is: how can I get my normal 1440x900@60hz resolution back? Thanks in advance for an answer.

2 Answers 2

1

I've struggled with the problem and found a very simple solution.

I have ubuntu 14.04.2 LTS running on my machine.

The solution is:

  • Xdiagnose

Use Xdiagnose from the Dashboard. (Xdiagnose is an analysis tool for troubleshooting X.org problems, and this is what you are experiencing.

  • Enable options under debug

Search for and launch Xdiagnose, then enable all the options under the Debug section. Click the Apply button, then close the window and restart the system.

the solution is also detailed here: linuxbsdos.com.

1
  • This worked for me on ubuntu 16.04 desktop x64, AMD processor.
    – user38537
    Jun 30, 2016 at 8:56
0

I would suggest trying to reconfigure the xserver on your computer. You might try

sudo dpkg-reconfigure xserver-xorg

If that doesn't work I would try doing the same for fglrx-updates.

1
  • I tried both, but nothing happens. With "sudo dpkg-reconfigure fglrx-updates" I do get the error message: "update-alternatives: warning: forcing reinstallation of alternative /usr/lib/fglrx/ld.so.cond because link group x86_64=linux-gnu_gl_conf is broken" Any ideas? Tia!
    – Harry
    Apr 20, 2015 at 20:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.