6

EDIT: PROBLEM IS BACK.. I cant figure out a permanent and reliable way around the bug (have managed the bug to go away 2 times) my files keep duplicating themselves with a ~ after their name, so if I modify rc.local, a file named rc.local~ pops out of nowhere, I dont understand what this does.

Also I dont have a /etc/init/module-init-tools.conf file, Im modifying the script in kmod.conf...

Help is appreciated.

EDIT: Problem solved thanks to https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1003297

I installed Ubuntu 14.04 LTS alongside Windows 7, my ethernet connection works without problem in Windows but it doesn’t work in Ubuntu. I think the problem is related to drivers and doesn’t allow me to aquire/assign an ip adress. Thank you for trying to help, Ill describe the problem ahead.

My wifi connection does work without problems. When I desable my wifi: my network manager tries to connect using the wired connection 1 and it always returns "Disconnected - you are now offline", and then it tries to connect again and the cycle repeats (Disconnected - yo are now offline).

Diagnosis info:

~$ lspci | grep Ethernet

00:07.0 Bridge: NVIDIA Corporation MCP61 Ethernet (rev a2)

~$ ifconfig

eth0
Link encap:Ethernet HWaddr bc:5f:f4:6f:26:c0
inet6 addr: fe80::be5f:f4ff:fe6f:26c0/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:0 errors:12 dropped:0 overruns:11 frame:1 TX packets:140 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:0 (0.0 B) TX bytes:27262 (27.2 KB)

lo
Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:65536 Metric:1 RX packets:1679 errors:0 dropped:0 overruns:0 frame:0 TX packets:1679 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:147779 (147.7 KB) TX bytes:147779 (147.7 KB)

About my ethernet controller: I dont understand much but here is the info I got:

~$ sudo lshw -class bridge

*-bridge description: Ethernet interface product: MCP61 Ethernet vendor: NVIDIA Corporation physical id: 7 bus info: pci@0000:00:07.0 logical name: eth0 version: a2 serial: bc:5f:f4:6f:26:c0 size: 100000000 capacity: 100000000 width: 32 bits clock: 66MHz capabilities: bridge pm msi ht bus_master cap_list ethernet physical mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation configuration: autonegotiation=on broadcast=yes driver=forcedeth driverversion=0.64 duplex=full latency=0 link=yes maxlatency=20 mingnt=1 multicast=yes port=MII speed=100Mbit/s resources: irq:44 memory:eeefd000-eeefdfff ioport:d080(size=8)

Finally I managed to get a script that diagnoses your connections, here is the output when my wifi is off and Im trying to connect trough my ethernet:

WARN: This system does not have a default route

INFO: Host localhost answers to ICMP pings

INFO: Loopback interface is working properly

INFO: The lo interface is up

INFO: The lo interface has IP address 127.0.0.1/8 ::1/128 assigned

INFO: The lo interface has tx and rx packets.

INFO: The eth0 interface is up INFO: The eth0 interface has IP address fe80::be5f:f4ff:fe6f:26c0/64 assigned ERR: The eth0 interface has not tx or rx any packets. Link down?

WARN: The eth0 interface has rx errors.

WARN: The wlan0 interface is down

ERR: The system does not have any nameserver configured

WARN: System does not seem to reach Internet host www.debian.org through ICMP WARN: Cannot access web server at Internet host www.debian.org

Thanks for reading and if you can help me out it will be greatly appreciated.

EDIT: $sudo lshw -class network

  *-network DISABLED      
   description: Wireless interface
   physical id: 1
   bus info: usb@1:4
   logical name: wlan0
   serial: 00:e0:4c:c0:c4:2c
   capabilities: ethernet physical wireless
   configuration: broadcast=yes driver=rtl8192cu driverversion=3.16.0-34-generic firmware=N/A link=no multicast=yes wireless=IEEE 802.11bgn

lsb_release -a

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.2 LTS
Release:    14.04
Codename:   trusty
  • 1
    Welcome to askubuntu.com Link down. eth0 interface has rx errors. Have you tried a different network cable? Please replace sudo lshw -class bridge with sudo lshw -class network and add the output of lsb_release -a Thank you for helping us help you! – Elder Geek Apr 20 '15 at 19:51
  • I just added the info requested, thank you for your help. I want to add that the cable works perfectly when I boot Windows 7. – Julian Uribe Apr 20 '15 at 20:01
  • How can I install a driver for my "Ethernet interface product: MCP61 Ethernet vendor: NVIDIA "? I think this might solve the issue. Thank you. – Julian Uribe Apr 20 '15 at 20:50
  • Problem solved! Thanks to whoever wrote this bugs.launchpad.net/ubuntu/+source/linux/+bug/1003297 – Julian Uribe Apr 20 '15 at 21:29
  • 1
    rc.local~ is a temp file your editor is creating. – Elder Geek Apr 21 '15 at 14:14
4

Note: I'm posting this workaround as an answer due to the number of times this has been reported as a bug only to expire shortly thereafter and resurface again.

Test

  1. Enter Ubuntu recovery mode: a. Power on system and press Shift during boot up for GRUB menu.

    b. Choose "Advanced options for Ubuntu" > Ubuntu, [kernel version] (recovery mode)

  2. Choose "root" and key in below commands:

    rmmod forcedeth
    modprobe forcedeth msi=0 msix=0
    exit
    
  3. Choose "resume" to resume normal boot

Now the network should be OK till next boot with AM3+ CPU.

If the workaround works on your system, please modify below file to automatically run the script when boot up:

Bug Workaround Solution:

  1. Add the line exec rmmod forcedeth at next line of "script" (above grep?) in the file /etc/init/module-init-tools.conf or /etc/init/kmod.conf)

  2. Add the line modprobe forcedeth msi=0 msix=0 to /etc/rc.local

  3. Restart the system to verify

Sources: Primarily Achkap post #16 http://ubuntuforums.org/showthread.php?t=2020571&page=2

https://bugs.launchpad.net/ubuntu/+s...x/+bug/1003297

https://bugs.launchpad.net/ubuntu/+bug/1264509

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1281930

Clue from Julian Uribe in comments.

  • For ubuntu 14.04 I could not find a module-init-tools.conf file, instead I modified the kmod.conf file in the same directory. – Julian Uribe Apr 20 '15 at 23:49
  • @JulianUribe It's right where it belongs in my Ubuntu 14.04 installation. What's your output of uname -a? – Elder Geek Apr 21 '15 at 1:28
  • Linux julian-desktop 3.16.0-34-generic #47~14.04.1-Ubuntu SMP Fri Apr 10 17:49:16 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux – Julian Uribe Apr 21 '15 at 13:53
  • @JulianUribe Thanks, I'll edit the answer. – Elder Geek Apr 21 '15 at 13:56
  • I edited the post explaining how I haven’t been able to figure out the bug in a permanent fashion, I don’t understand why, but after rebooting the forcedeth fix stops working. I’m quite lost. – Julian Uribe Apr 21 '15 at 14:00
0

Add "forcedeth msi=0 msix=0" to /etc/modules. This way you won't have to stop the loaded module and reload it with the proper options as it sould be loaded properly to begin with.

Sources:

Previous clues in comments and other answer.

http://ubuntuforums.org/archive/index.php/t-1982856.html

  • This was the first fix I tried, and I let the file that way so I suppose that’s not a guaranteed fix on its own. – Julian Uribe Apr 21 '15 at 14:59
  • A suggestion in this question askubuntu.com/questions/612076/… worked the first time, I hope its the fix I needed. The suggestion was to create a forcedeth.conf file with the options. – Julian Uribe Apr 21 '15 at 15:00
  • Thanks for your help Elder, I think the modules fix used to work before, but in the new versions it doesn’t work any more, I tried that modification on its own at first, as it is suggested in the bug report I linked. – Julian Uribe Apr 21 '15 at 15:17
  • Can anyone confirm this doesn't work with the 32-bit varieties? – Elder Geek Apr 21 '15 at 15:22

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.