2

Today I updated Ubuntu 14.04 and Makerware was removed! I tried to install it and got his message:

$ sudo apt-get install makerware
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 makerware : Depends: libqt5multimedia5 (>= 5.0.2) but it is not going to be installed
         Depends: libqt5multimediawidgets5 (>= 5.0.2) but it is not going to be installed or
                  libqt5multimediawidgets5-gles (>= 5.0.2) but it is not installable
E: Unable to correct problems, you have held broken packages.

I tried to install the missing package and got this message:

$ sudo apt-get install libqt5multimedia5
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libqt5multimedia5 : Depends: qtbase-abi-5-2-1
E: Unable to correct problems, you have held broken packages.

I then tried to install that package, and found myself here:

$ sudo apt-get install qtbase-abi-5-2-1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package qtbase-abi-5-2-1 is a virtual package provided by:
  libqt5core5a 5.2.1+dfsg-1ubuntu14.2 [Not candidate version]
  libqt5core5a 5.2.1+dfsg-1ubuntu14 [Not candidate version]

E: Package 'qtbase-abi-5-2-1' has no installation candidate
$ sudo apt-get install libqt5core5a
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libqt5core5a is already the newest version.

The package libqt5core5a is already installed and so I am stuck.

2

I installed aptitude and got these proposed solutions:

$ sudo aptitude install makerware
The following NEW packages will be installed:
  avrdude{a} conveyor{a} conveyor-common{a} conveyor-ui{a} libarmadillo4{a} 
  libarpack2{a} libboost-program-options1.54.0{a} libcoin80{a} libdap11{a} 
  libdapclient3{a} libdigitizer{a} libepsilon1{a} libfreexl1{a} libftdi1{a} 
  libgdal1h{a} libgeos-3.4.2{a} libgeos-c1{a} libgraphicsmagick3{a} 
  libhdf4-0-alt{a} libhdf5-7{a} libjsoncpp0{a} libkml0{a} libmbqtutils{a} 
  libmysqlclient18{a} libnetcdfc7{a} libogdi3.2{a} libopenmesh-3.2{a} 
  libopenscenegraph99{a} libopenthreads14{a} libpq5{a} libproj0{a} 
  libqt5multimedia5{ab} libqt5multimediawidgets5{a} libspatialite5{a} 
  libthing{a} libtinything{a} libtoolpathviz{a} liburiparser1{a} 
  libxerces-c3.1{a} libxine2{a} libxine2-bin{a} libxine2-doc{a} 
  libxine2-ffmpeg{a} libxine2-misc-plugins{a} libxine2-plugins{a} 
  makerbot-driver{a} makerware mb-libjsonrpc{a} mb-libopencv2.4{a} 
  mb-libstdc++6{a} mb-libvtk5.10{a} mb-pyserial{a} miracle-grue{a} 
  mysql-common{a} proj-bin{a} proj-data{a} 
0 packages upgraded, 56 newly installed, 0 to remove and 0 not upgraded.
Need to get 206 MB/206 MB of archives. After unpacking 340 MB will be used.
The following packages have unmet dependencies:
 libqt5multimedia5 : Depends: qtbase-abi-5-2-1 which is a virtual package.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     libqt5multimedia5 [Not Installed]                  
2)     libqt5multimediawidgets5 [Not Installed]           
3)     makerware [Not Installed]                          



Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

      Remove the following packages:                                            
1)      libqt5help5                                                             
2)      libqt5xmlpatterns5                                                      
3)      musescore                                                               
4)      qml-module-qtquick-localstorage                                         
5)      qml-module-qtquick-window2                                              
6)      qml-module-qtquick2                                                     
7)      qml-module-qtwebkit                                                     

      Install the following packages:                                           
8)      libqt5positioning5 [5.2.1-1ubuntu2 (now, trusty)]                       
9)      libqt5sensors5 [5.2.1+dfsg-2ubuntu2 (now, trusty)]                      

      Downgrade the following packages:                                         
10)     libqt5clucene5 [5.3.0-5~trusty1 (now, trusty) -> 5.2.1-8build1 (trusty)]
11)     libqt5core5a [5.3.0+dfsg-2ubuntu9~trusty1 (now, trusty) -> 5.2.1+dfsg-1u
12)     libqt5dbus5 [5.3.0+dfsg-2ubuntu9~trusty1 (now, trusty) -> 5.2.1+dfsg-1ub
13)     libqt5gui5 [5.3.0+dfsg-2ubuntu9~trusty1 (now, trusty) -> 5.2.1+dfsg-1ubu
14)     libqt5network5 [5.3.0+dfsg-2ubuntu9~trusty1 (now, trusty) -> 5.2.1+dfsg-
15)     libqt5opengl5 [5.3.0+dfsg-2ubuntu9~trusty1 (now, trusty) -> 5.2.1+dfsg-1
16)     libqt5printsupport5 [5.3.0+dfsg-2ubuntu9~trusty1 (now, trusty) -> 5.2.1+
17)     libqt5qml5 [5.3.0-3ubuntu13~trusty1 (now, trusty) -> 5.2.1-3ubuntu15.1 (
18)     libqt5quick5 [5.3.0-3ubuntu13~trusty1 (now, trusty) -> 5.2.1-3ubuntu15.1
19)     libqt5sql5 [5.3.0+dfsg-2ubuntu9~trusty1 (now, trusty) -> 5.2.1+dfsg-1ubu
20)     libqt5sql5-sqlite [5.3.0+dfsg-2ubuntu9~trusty1 (now, trusty) -> 5.2.1+df
21)     libqt5svg5 [5.3.0-2~trusty1 (now, trusty) -> 5.2.1-1 (trusty)]          
22)     libqt5test5 [5.3.0+dfsg-2ubuntu9~trusty1 (now, trusty) -> 5.2.1+dfsg-1ub
23)     libqt5webkit5 [5.3.0+dfsg-1ubuntu2~trusty1 (now, trusty) -> 5.1.1-1ubunt
24)     libqt5webkit5-qmlwebkitplugin [5.3.0+dfsg-1ubuntu2~trusty1 (now, trusty)
25)     libqt5widgets5 [5.3.0+dfsg-2ubuntu9~trusty1 (now, trusty) -> 5.2.1+dfsg-
26)     libqt5xml5 [5.3.0+dfsg-2ubuntu9~trusty1 (now, trusty) -> 5.2.1+dfsg-1ubu
27)     qtdeclarative5-localstorage-plugin [5.3.0-3ubuntu13~trusty1 (now, trusty
28)     qtdeclarative5-qtquick2-plugin [5.3.0-3ubuntu13~trusty1 (now, trusty) ->
29)     qtdeclarative5-window-plugin [5.3.0-3ubuntu13~trusty1 (now, trusty) -> 5



Accept this solution? [Y/n/q/?]

It seems that when I added the repository for MuseScore and upgraded MuseScore to 2.0, it also updated qt to 5.3 which seems to be incompatible with Makerware.

For now, it looks like I have to downgrade MuseScore or not use Makerware.

0

You need to run command first download and manually install MySQL Workbench:

sudo apt-get -f install

Run only this command, it will fix your issue.

It worked for me on Linux Mint

  • 1
    No, you don't understand. There are packages that conflict so that I cannot have Makerware and MuseScore 2.0 installed. – HarlemSquirrel Apr 11 '16 at 3:02

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.