5

I have a problem logging into Ubuntu under all of my usernames. I have tried many solutions. When I look at my .xsession-errors file, I get the following:

xlib: extension "GLX" missing on display ":o"
Script for ibus started at run_im.
Script for auto started at run_im.
Script for default started at run_im.
init: gnome-session (unity) main process (2292) terminated with status 1
init: unity-settings-deamon main process (2284) killed by TERM signal
init: logrotate main process (2192)killed by TERM signal
init: update-notifier-crash (/var/crash/_usr_bin_compiz.1000.crash) main process (2230) killed by TERM signal
init: xsession-init main process (2201) killed by TERM signal
init: hud main process (2288) killed by TERM signal
init: unity=panel service main process (2299) killed by TERM signal
init: Disconnected from notified D-Bus bus
init: window-stack-bridge main process (2215) killed by KILL signal
  • Have you tried this question: Ubuntu gets stuck in a Login Loop? – karel Apr 20 '15 at 17:33
  • 1
    Yes those solutions did not work. I tried the chmod username:username solution to no avail as well as some of the other suggestions on there – Ben Apr 20 '15 at 17:36
  • Is it when you try to login you get kicked back to the login screen? Try pressing ctrl + alt + F2 to drop to a command shell, login, and then run sudo apt-get remove --purge lightdm and then sudo apt-get install lightdm. If that doesn't work, try sudo apt-get install gdm. – TheWanderer Apr 20 '15 at 17:36
  • I know in your other question you had mentioned installing gdm, were you attempting to install gnome? You could try reinstalling the Unity Desktop Environment. – Ian Apr 20 '15 at 17:40
  • @Zacharee1 The lightdm fix did not work. And I already tried the gdm fix and that did not work. – Ben Apr 20 '15 at 18:51
1

Short Solution

Try to install linux-headers-generic and reboot to login again:

# apt-get install linux-headers-generic

Longer Story

Same issue here. I've tried serveral ways in askubuntu and stackoverflow but in vain. I write down my solution and hope it will help others.

This issue happens after I use apt-get purge to remove all kernels accidentally, then I install linux-image-generic and hope everything is ok. However, I meet this issue after reboot, .xsession-errors shows almost same message (just pids are different).

After one hour, I found linux-headers-generic is not just header files. It will also recompile necessary components. In my case it's nvidia driver.

After install linux-headers-generic and reboot, everything is back to normal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.