2

Three boxes running three different ubuntu flavours (14.04, 14.10, 15.04). I'm trying to get all of these to talk between themselves, while being on different subnets, and I can't figure how, yet.

Problem is that my ISP provides a router for the TV, phone and internet. We cannot change the hub's lan range (192.168.2.0/24), while my lan with my own router is on 10.0.0.0/13 (and I don't want to change it).

Here's the setup: enter image description here

My ISP's hub/router is on 192.168.2.1, so that's the gw facing internet. My own router is connected (DHCP) to this router, its LAN address is thus in 192.168.2.0/24 .

I have PC1, PC2 and PC3 in 10.0.0.0/13, going on the Net thru my own router, which is connected onto my ISP-provided router in 192.168.2.0/24. Those PCs can connect onto my 192.168.2.1.

Now, I have to connect a PC directly onto my ISP-provided router; it'll have a 192.168.2.0/24 address, and cannot see other devices into 10.0.0.0/13 . I'm not that well-versed in routing, I'm wondering what can I do to get it to see PCs onto 10.0.0.0/13 ?

Oh, and the easy way is out : I cannot add a static route on 192.168.2.1 (the ISP gateway).

Any ideas?

--Jeff

  • I always modify my ISP's router internal IP to suit my needs so I've never attempted this with the restrictions you state. I'll be watching this for answers though.... – Elder Geek Apr 20 '15 at 15:21
  • You might find this interessting: linuxquestions.org/questions/linux-networking-3/… post 11 may provide some clues – Elder Geek Apr 20 '15 at 15:25
  • Elder Geek : that's what I'd done, but my ISP's router is quite dumb (or assuming most of its users are !). Not much I can change on it. First thing I'd have done would be to switch its LAN config to suit my own on 10.0.0.0/13, or add a static route on its config, but no, I can't. – J.F.Gratton Apr 20 '15 at 15:48
  • 1
    Disable firewall and NAT on your router, then create a static route in the PC on 10.0.0.0/13 network pointing to your router's WAN: route add -net 10.0.0.0/13 gw 192.168.2.X – Eric Carvalho Apr 20 '15 at 16:01
  • 1
    Accordingly to your diagram, you should add the route to PC#3 (the one with IP address 192.168.2.101): route add -net 10.0.0.0/13 gw 192.168.2.21. – Eric Carvalho Apr 20 '15 at 18:57
2

You should add the route to PC#3 (the one with IP address 192.168.2.101):

route add -net 10.0.0.0/13 gw 192.168.2.21

Or you can edit your network connection to automatically include a static route when the connection is established (IPv4 Settings tab -> Routes button):

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.