I am a beginner at using linux and I have been trying to get Ubuntu to work with the ASUS ZenBook UX303LAB (Broadwell version). I am having problems with Brightness keys, keyboard backlight brightness toggle keys, and the touchpad. The touchpad is of less importance than the laptop brightness. Using 14.04.02 LTS, I have tried the various grub lines (specifics below) to no avail. I tried 14.10 which resolved the keyboard brightness keys not working but nothing outside of that.

Please note, that I am using Ubuntu with XFCE desktop. Not sure if that matters but I wanted to provide as much info as possible.

Tried variations of the CMDLINE acpi in grub noted below. I would update it, run update-grub and reboot.

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=" and then : update-grub

Did not work

  • Tried grub line as acpi_osi=Linux acpi_backlight=vendor

Did not work

  • Tried installing xbacklight.

    Did not work. Settings had no affect.

  • Tried installing backlight program in Ubuntu Software Center in 14.10. That allowed me to workaround by going up to the system tray, clicking the power drop down and lower the brightness. However, it defaults back to 100% brightness after rebooting. Would like it to be permanent if the hot keys won't work.

An odd thing I noticed was that after installing Steam in Ubuntu 14.10, launching steam seemed to freeze up the laptop.

Any assistance would be greatly appreciated.

Here are the forums I went through to reference where I got the grub lines from:

Asus Zenbook UX303 Problems
Asus UX32LN: Brightness keys Fn+F5 and Fn+F6 don't generate evdev event.

  • Is there any solution for the brighness keys? acpi_osi= does not work.
    – meles
    May 26 '15 at 18:39
  • Make shure that there is a whitespace after the '=' -> so 'acpi_osi= ' Jan 9 '20 at 7:34

For your model 'acpi_osi=' should work. Don't forget to update-grub. Try to look if Fn+F5 and F6 generate evdev events.

If you have Intel graphics, to get these buttons really working you will have to point xorg to intel_backlight.

This can be done by adding a file 20-backlight.conf to /usr/share/X11/xorg.conf.d with

Section "Device"
    Identifier "card0"
    Driver "intel"
    Option "Backlight" "intel_backlight"
    BusID "PCI:0:2:0"



The issue with the touchpad is caused by the trusty and utopic kernels not fully supporting it. Full support for that touchpad is available in kernel 4.0+ so I would recommend downloading and installing the latest stable kernel (currently 4.0.3) onto your system and testing it out, it works flawlessly on my UX303LAB laptop.

mkdir /tmp/kernel-mainline_4.0.3
cd /tmp/kernel-mainline_4.0.3

wget \
    http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0.3-wily/linux-headers-4.0.3-040003-generic_4.0.3-040003.201505131441_amd64.deb \
    http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0.3-wily/linux-headers-4.0.3-040003_4.0.3-040003.201505131441_all.deb \

sudo dpkg -i /tmp/kernel-mainline_4.0.3/linux*4.0.3*.deb

I have a fresh install of 15.04, but the tip from the Arch Wiki worked in Ubuntu as well (I had Arch a short while ago but I missed a functioning Unity DE). Set the following line in your grub (/etc/default/grub):

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video.use_native_backlight=0"

The default of 3.16 and newer kernels is backlight=1. After editing the file run sudo update-grub and reboot. Your mileage may vary though. It's much less complicated than creating a x11 config and if you type it wrong you should still boot just fine and be able to edit it.


Try GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=force acpi_osi=" worked for me. I also did the 20-intel.conf fix and updated my kernel to 3.16

running 14.04 with kernal 3.16 on an Asus X551MA

Here is the thread with details on each step;

Fn+F5,F6 keys to adjust brightness doesn't work


I've managed to solve the problem with my own solution for the Zenbook UX305LA I hope this solution works also for you all.

It makes use of two scripts:

  1. brightness is a script that increases or decreases the brightness
  2. You have to edit the sudoers file to make it executable as sudo without the password
  3. Create a shortcut using the python3 script called the_script.py

The current solution is working on Ubuntu 14.04 and Asus Zenbook UX305LA

You can find the code here


The shortcut creator (point 3) seems not work for Ubuntu 16.04, to make it work I created it using: Settings -> Keyboard -> Shortcuts -> Custom Shortcuts.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.