3

I run VNC Server on a headless Windows 7 box serving as a print & file server. When I connect with Remmina on Ubuntu 14.04, closing any window on the remote desktop closes the connection.

Here is the scenario:

  1. I connect to the server and see the remote desktop.
  2. I double-click Computer on the desktop and a window opens.
  3. I click the red X in the right corner of the window.

Expected result: window closes Actual result: window closes and connection closes

Here are other configs I have tried in an effort to isolate the problem:

32 bit Ubuntu 12.04 virtual machine  - no problem
32 bit Ubuntu 12.04 netbook          - no problem
64 bit Ubuntu 14.04 virtual machine  - no problem
64 bit Ubuntu 14.04 desktop pc       - problem occurs
32 bit Ubuntu 14.10 virtual machine  - no problem
64 bit Ubuntu 15.04 virtual machine  - no problem
64 bit Lubuntu 14.04 virtual machine - no problem
32 bit Lubuntu 14.10 virtual machine - no problem
Android tablet with VNC viewer       - no problem

I believe this to be an issue with or setting in my Remmina client on the desktop Ubuntu 14.04 rather than a VNC server issue because it works properly with all other tested configurations. Annoying, because that is my main PC and the one I'm most likely to use to work on the server.

The obvious workaround is to use one of the VMs, but can anyone suggest a plan of attack for getting the desktop 14.04 version working?

3

I had all kinds of issues including yours with remmina, but I recently installed the new rc version and it fixed everything. I wouldn't normally recommend a release version but the normal remmina was way too buggy. it also adds a ton of new features. Highly recommend.I love it!The version is Remmina 1.2.0rcgit.3

  • Thanks...about a month after I asked this question, I nuked the Windows 7 computer and converted it to Lubuntu. I've had no issues with remmina since then. – Organic Marble Aug 7 '15 at 21:57
1

I am not sure why this helped, but when I set the connection quality to "Best", the undesired behavior went away. The other connections that worked, were set to "Poor"....

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.