0

Situation

I've installed Ubuntu 14.04 on my desktop, and now need to get Apache 2.4 working with my local websites. With 12.04 this all worked. Now I get two errors, and googling for these errors I find many suggestions, but none seem to work.

<VirtualHost *:80>
        ServerName test.local
        DocumentRoot /var/www/htdocs/test

        DirectoryIndex index.php
        <Directory /var/www/htdocs/test>
                RewriteEngine On
                AllowOverride All
                Options +FollowSymLinks +Includes
                Require all granted
        </Directory>

        SetEnv config "ubuntu-desktop"
</VirtualHost>
  • I use symlinks and cannot avoid them totally.
  • The include path is absolute, not relative.
  • I've changed the owner of all files and folders to www-data.
  • I've set rights to 777 for all files and folders, without luck.
  • The rewrite module is loaded.
  • I've tried several things with the Options, and even "all" doesn't change anything.

Questions

  • How can I get includes and htaccess working?
  • Do I need to change anything in php.ini?
  • 1
    You might want to add more information like the exakt error messages and whether you checked all the files and directories and their respective permissions. Some hints that could maybe help you: - Apache 2.4 changed its docroot from 2.2. It's now /var/www/html/ instead of /var/www/ - According to linux.m2osw.com/… pcfg_openfile seems to have something to do with the permissions of the directory the htaccess is in. - The "Includes" from the Apache conf are not PHP's "include", but Server Side Includes. – Henning Kockerbeck Apr 21 '15 at 8:13
0

This is my desktop, and I encrypted my home folder. Website projects are in my home folder, in the encrypted part. This seems to be problematic, probably because the apache user has no rights for my home folder. After moving the Eclipse workspace folder outside my home folder it all started working.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.