I was trying to install MySql on my system running Ubuntu 14.04. So I added a MySql apt from the link Steps to fresh install MySql.
After running into a lot of trouble and realizing apt uses libs not supported by Ubuntu 14.04, I was advised to remove the apt and use Ubuntu repo to install mysql.

However, it seems I can't find how to remove the above mentioned apt repo. I've been through some of the stuff I can find on the community but still no solution that worked for me! Software center shows this.

Tried using dpkg, aptitude -remove also from software center but looks like I've hit a wall.
So any help is appreciated.

  • have you tried sudo apt-get purge mysql* and remove /etc/apt/sources.list and do sudo apt-get update again. Apr 20, 2015 at 11:45
  • 1
    @mnstalemate "remove /etc/apt/sources.list" ? Why that?
    – A.B.
    Apr 20, 2015 at 11:51
  • Yes, I did that, though I used 'mysql*' as the reg exp, just to be safe.
    – neo.one
    Apr 20, 2015 at 13:07
  • @A.B so that when you update your repositories again, you won't have any manually added repos in the sources.list file. Apr 21, 2015 at 16:49
  • @mnstalemate So, wouldn't that affect other manually added repos?
    – neo.one
    Apr 22, 2015 at 3:42

2 Answers 2


So I added a MySql apt from the link Steps to fresh install MySql

When those are really the steps that you followed, then this is your solution.

Open a terminal and run this command if you want to remove all configurations:

sudo apt-get purge mysql-apt-config

Otherwise, this command is sufficient:

sudo apt-get remove mysql-apt-config
  • Done, no success.
    – neo.one
    Apr 20, 2015 at 13:07
  • @neo.one The repository is still displayed in Synaptic?
    – A.B.
    Apr 21, 2015 at 16:54
  • Yes, it is displayed in Synaptic
    – neo.one
    Apr 22, 2015 at 3:40
  • Execute this command and write the output into your question: find /etc/apt/ -type f | xargs grep "repo.mysql.com"
    – A.B.
    Apr 22, 2015 at 6:03

I found that /etc/apt/sources.list.d/mysql.list had all the references to mysql repositories:

pi@raspberrypi:~ $ find /etc/apt/ -type f | xargs grep "repo.mysql.com"
/etc/apt/sources.list.d/mysql.list:deb http://repo.mysql.com/apt/debian/ stretch mysql-apt-config
/etc/apt/sources.list.d/mysql.list:deb http://repo.mysql.com/apt/debian/ stretch mysql-5.7
/etc/apt/sources.list.d/mysql.list:deb http://repo.mysql.com/apt/debian/ stretch mysql-tools
/etc/apt/sources.list.d/mysql.list:#deb http://repo.mysql.com/apt/debian/ stretch mysql-tools-preview
/etc/apt/sources.list.d/mysql.list:deb-src http://repo.mysql.com/apt/debian/ stretch mysql-5.7

So I decided to remove the mysql.list i the /etc/apt/sources.list.d directory and finaly sudo apt-get update does not come with mysql repositories

Thanks every one here

  • I posted as new answer because of reputation sorry Aug 28, 2018 at 19:18
  • Why is this not an answer? The last line is what the OP did to solve the issue.
    – terdon
    Aug 29, 2018 at 9:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.