0

This question already has an answer here:

I just rebuilt my HTPC with an ASRock AM1H-ITX mobo, an AMD 5350 APU, a stick of Crucial Ballistix 1600 8GB DDR3 RAM and a Crucial BX100 250 GB SSD. I decided to try Ubuntu 14.04 as my stand alone OS. Went through the entire install without a hitch until right before the end, when an error message came up saying some four letter file beginning with a g couldn't be installed in my / partition. I quickly chose another location randomly, and by the time I did this, it said the install was done and to restart. After the reboot, the Ubuntu screen came up telling me to push enter to eject the Ubuntu DVD, which I did when everything went black. Tried resetting and restarting the computer, but all I can get into is the ASRock motherboard utility. Otherwise it boots black.

Help...

marked as duplicate by Elder Geek, Panther, Eric Carvalho, Maythux, Kevin Bowen Apr 21 '15 at 21:38

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    That "file" that couldn't be installed was the GRUB bootloader. Ubuntu won't work without it. Try re-running the installation and post the EXACT error message here, – TheWanderer Apr 19 '15 at 20:49
  • I can't rerun installation. The Live CD will not load when I boot. I get a couple seconds of ASRock UEFI info and a fast chance to enter UEFI, and than to a black screen. – sgcroxton Apr 19 '15 at 23:49
  • Sorry, but you'll need to find a way to boot from a live DVD or USB medium. No way around that. It worked before, so it's probably just a configuration issue of the BIOS. Take a look at its manual and check setting like Secure Boot and the boot medium choice. – David Foerster Apr 21 '15 at 16:36
1

That means GRUB couldn't be installed. GRUB is the bootloader used by many Linux distributions. To fix this, boot into the LiveCD session of Ubuntu. The easiest way to fix it is by opening the terminal (Ctrl-Alt-T) and typing in sudo grub-install /dev/sda

To explain: / is your computer's root folder. This is where everything else comes from. dev means device. sda is your computer's main hard drive (SSD in this case).

This should fix the issue. Just ask if it doesn't.

  • The Live CD won't boot. The only thing I have access to is the ASRock UEFI setup utility. – sgcroxton Apr 19 '15 at 23:40
  • @sgcroxton Are you able to change any settings in UEFI? – Terrance8D Apr 20 '15 at 16:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.