2

On synaptic, I want to install dkpg-dev, but synaptic need to downgrade libdkpg-perl for this. Is it a good idea to allow that or I will run into broken packages issues. What rule of thumb do you use in this cases ? I have a newly installed Ubuntu 14.04. How come I run into this ? Thank you. .

.

-------------------------------- EDIT 1

Here is my sources.list:

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://us.archive.ubuntu.com/ubuntu/ trusty main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty main restricted

## Major bug fix updates produced after the final release of the
## distribution.

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the    Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://us.archive.ubuntu.com/ubuntu/ trusty universe
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the    Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://us.archive.ubuntu.com/ubuntu/ trusty multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu trusty partner
# deb-src http://archive.canonical.com/ubuntu trusty partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu trusty main
deb-src http://extras.ubuntu.com/ubuntu trusty main

and my /etc/apt/sources.list.d/ is empty

. -------------------------------- EDIT 2

Actually, I re-installed libdkpg-perl. It was

"installed version: 1.17.5ubuntu5.3 and latest: 1.17.5ubuntu5"

I am not sure how I get to this. Is it due to my sources.list ?

After I re-installed, I have:

"installed version: 1.17.5ubuntu5 and latest: 1.17.5ubuntu5"

It is equivalent to a downgrade

.

  • Try running apt-get update and then apt-get upgrade. I think you may be trying to install an outdated version of dpkg-dev. – TheWanderer Apr 19 '15 at 14:14
  • I don't want to upgrade though – Bob Yoplait Apr 19 '15 at 17:50
  • apt-get upgrade only updates your packages; it doesn't upgrade your Ubuntu installation. apt-get dist-upgrade will upgrade to a newer version of Ubuntu. – TheWanderer Apr 19 '15 at 18:14
2

Perform the following commands in a terminal, in order to update the package sources:

sudo apt-get update

Then run the installation of dkpg-dev again:

sudo apt-get install dkpg-dev

Based on your sources.list and an empty /etc/apt/sources.list.d, accepting the downgrade should pose no problem.

  • When I do the update and go back to synaptic, I have the same behaviour as before – Bob Yoplait Apr 19 '15 at 17:49
  • @BobYoplait After update and install? – A.B. Apr 19 '15 at 17:58
  • after update, I go to synaptic to try to instal again dkpg-dev, and it still ask me for downgrade of libdkpg-perl. If I do it from the command line, I get:"libdpkg-perl (= 1.17.5ubuntu5) but 1.17.5ubuntu5.3 is to be installed" – Bob Yoplait Apr 19 '15 at 18:05
  • @BobYoplait Which package sources do you use? – A.B. Apr 19 '15 at 18:27
  • 1
    @BobYoplait accept the downgrade 😊 – A.B. Apr 19 '15 at 20:19
1

You may allow it, that's not a problem. The packages synaptic offers are the dependencies of the packages you want to install.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.