17

Sometimes when I open Libre Writer document it doesn't show its window.

But I can see from the launcher that in fact it is open.

When I opened multiple documents, the same behaviour - if I click on the Writer's launcher, invisible windows hover - only close buttons are seen.

The problem was solved after I deleted configuration files of libreoffice from /home/.config directory and entered through Libre Office from the Dash.

But, what caused the problem?

0

5 Answers 5

18

Resize the window using unity keyboard shortcuts

This happened to me in LibreOffice Calc on Ubuntu 14.04.

  1. Press Alt+Space, R.

  2. Then move your mouse to desired window size.

1
  • 2
    Wonderful solution. Good to know about this alt+space feature! Jun 13, 2019 at 5:53
7

Following steps might help

  1. Use Alt + tab to navigate to LibreOffice
  2. Change the view to 'full screen' using Shift + Ctrl + j
  3. Use Windows + s to see all workspaces
  4. Click on LibreOffice, drag it below until you see the maximize option on top left
  5. double-click somewhere on the work space with LibreOffice
  6. Upon maximizing the workspace, click on the maximize button in LibreOffice (top left)

You should get your LibreOffice normal view back.

Tested on: Ubuntu 16.04

2
  • 1
    Indeed, playing with shift+ctrl+j allowed the resize/reduce/close window buttons to be back... I have no idea why Open Office didn't show these buttons on 1st start and needs such madness to make them appear : )
    – Xenos
    Jan 11, 2020 at 10:57
  • shift-ctrl+j and then just closing the window with alt+f4 fixed it for me. Writer UI showed up properly after.
    – dvdgsng
    Mar 7, 2023 at 8:49
5

I'm not sure if this will help anyone with troubleshooting, but you can re-size those windows to get them to display.

(I had this happen in Impress, and I could not for the life of me figure out what was wrong for two weeks).

1
  • I had the same problem and resizing the window using keyboard shortcuts helped me (i had no resize buttons) thank you!
    – Rabbit
    Feb 6, 2016 at 15:38
2

To make the window visible is "easy", but it is annoying to do it every time.

To prevent it for the next time:

You have to reset the value FactoryWindowAttributes:

1. Solution:

  1. Open ~/.config/libreoffice/4/user/registrymodifications.xcu
  2. delete all lines containing FactoryWindowAttributes

2. Solution:

  1. Open LibreOffice Tools > Options > LibreOffice > Advanced > Open Expert Configuration (German: Extras > Optionen > LibreOffice > Erweitert > Experteneinstellungen...)
  2. FactoryWindowAttributes and click search
  3. Reset the values of TextDocument and SpreadsheetDocument

source

Solution1:

Solution2:

0

new on Ubuntu 22.04 I had this problem as well. Either full screen or minimize. No size adjustment... After reading all these nice tips, one thing sorted it for me: Under "Extras - options - view: disable the hardware acceleration! Hope it helps others.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .