1

I need to install my Nvidia driver. In order to do that I need to stop the X server. Stopping X server:

sudo service lightdm stop

makes my screen go blank. Trying Ctrl-Alt-F1 first makes my screen go blank as well. All I can do in both scenarios is a hard reboot.

1

This was fixed by uncommenting the GRUB_TERMINAL line in GRUB's config file, for example, you could use sed:

sudo sed -i 's/#GRUB_TERMINAL/GRUB_TERMINAL/' /etc/default/grub

Or you could do

sudoedit /etc/default/grub

find the line #GRUB_TERMINAL and remove the #from the start. Save and exit.

Either way, after editing the file, you must run

sudo update-grub

to make the changes effective.

0

You can disable lightdm by running

sudo systemctl disable lightdm.service

then reboot and install your driver, then

sudo systemctl enable lightdm.service --now

when you're done

I might be wrong on the name of the service, or even the whole method

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.