I installed Ubuntu 11.10 beta when it was released a couple of weeks ago. Everything is working fine.

Later I installed GNOME shell and then upgraded it from the gnome-shell testing ppa. I also installed and enabled all the gnome-shell-extensions available on the ppa. There is only one problem. When ever I switch to a theme which has a transparent gnome-shell menu I see nautilus menu behind it.

enter image description here

It only disappears when I quit nautilus. I don't know I to get rid of it so that I can use use themes like Nord and Malys properly.


That actually happens with the official Gnome Shell packages in Ubuntu 11.10 too (at least for me, at the time I'm posting this answer).

I only know a fix for this: disabling Nautilus from handling the desktop (so using this, you won't have icons on the desktop anymore). To do this, install "dconf-tools":

sudo apt-get install dconf-tools

Then launch "dconf-editor", navigate to org > gnome > desktop > background and uncheck the "show-desktop-icons" box.

| improve this answer | |
  • 1
    Thanks buddy, I used gnome-tweak-tool to disable nautilus from handling the desktop and now it works – Syed Khalil Sep 13 '11 at 1:55

AFAIK this is a bug in nautilus that occurs when ever there is no window manager running, and apparently also happens in GNOME Shell. I'm still trying to figure out myself what triggers it specifically, so I can report a bug with the correct details.

I believe it is probably already noticed by the developers however.

Hopefully, as 11.10 is still not at a final release, this bug should be fixed by the release date.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.