0

when i try to launch steam a message pops up- you are missing the following 32-bit libraries,and steam may not run: libic.so.6 I tried a get apt-update but the message still pops up anybody know how to fix?

1

2 Answers 2

2

The command apt-get update only refreshes your sources; it doesn't do anything else. What you need to do is run this:

sudo apt-get install '^libc6.*'

That will install the required package for you.

3
  • And why '^libc6.*'? This makes a lot of packages are installed that are not necessary.
    – A.B.
    Apr 19, 2015 at 13:39
  • @A.B. I did some research and this was what was suggested. Apr 19, 2015 at 14:04
  • @A.B. There's also the possibility that libic.so.6 isn't the only missing package. Also libic.so.6 isn't a stand-alone package, and needs the other stuff to be installed. Don't downvote an answer just because you think it installs too much, when in fact that "too much" needs to be installed. Apr 19, 2015 at 14:08
1

In order to easily install all the libraries you can use the terminal command :

sudo apt-get install ia32-libs

Hope this helps.

1
  • The difference was that I didn't use sudo apt-get install '^libc6.*', I used sudo apt-get install ia32-libs. I have used the one I put in the answer before and it worked, I haven't tried the other one. I hope this justifies my point.
    – Apad121
    Apr 19, 2015 at 22:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.